PhonerLite Index

German flag | Deutsch | Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
English flag | English | Easy to use VoIP softphone with profile and contact management
Russian flag | Русский | Легкий в использовании VoIP софтфон с управлением профилями и контактами

screenshot of PhonerLite

(C) Heiko Sommerfeldt


PhonerLite Deutsch

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch Russisch Russisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Was ist PhonerLite?

PhonerLite ist eine übersichtliche und leicht zu bedienende Anwendung für Windows, die es ermöglicht, unkompliziert den PC als Internet-Telefon ( VoIP , Voice over IP ) zu nutzen.Als Voraussetzungen für den Betrieb des Softphones (Software Phone) dienen lediglich eine full-duplexfähige Soundkarte , ein Mikrofon und Lautsprecher (wahlweise ein Headset ), eine Internet-Verbindung, und die Registrierung bei einem Anbieter, der VoIP über das Protokoll SIP unterstützt. PhonerLite unterstützt mehrere SIP-Profile, die unabhängig voneinander konfiguriert werden können. Ebenso übersichtlich wie leicht bedienbar ist das integrierte Telefonbuch und die Anrufprotokollierung.

PhonerLite unterstützt aktuelle Verschlüsselungs Methoden wie TLS, SRTP und ZRTP.

Wieso heißt PhonerLite eigentlich so?

  • Phoner: Es gibt das Programm Phoner , mit welchem sich PhonerLite eine gemeinsame Code Basis und die "sipper.dll" teilt. Die VoIP-Einstellungen sind 1:1 die gleichen. Konfigurierte VoIP-Profile lassen sich ohne Änderung in PhonerLite und umgekehrt benutzen. Sind Phoner und PhonerLite im gleichen Verzeichnis installiert, so teilen sich beide die DLL und die dazugehörigen Einstellungen (sipper.ini). Im Grunde benutzt PhonerLite nur eine andere GUI als Phoner.
  • Lite: Wie bei Coca-Cola light suggeriert der Namenszusatz eine "leichte" Variante des Originalprodukts. Bei PhonerLite spart man keine Kalorien , sondern Ressourcen - in diesem Fall also Speicherbedarf und vor allem Einarbeitungszeit. Die Handhabung ist bewusst einfacher als bei Phoner gehalten. Dieser Vorteil hat auch ein paar Nachteile: So werden nicht alle Leistungsmerkmale von Phoner unterstützt. Es gibt hier keinen Anrufbeantworter und keine Unterstützung für TTS .

Ist PhonerLite kostenlos?

JA! PhonerLite ist Freeware. PhonerLite darf kostenlos im Privat- als auch Geschäftsumfeld genutzt, kopiert oder wieder zum Download bereitgestellt werden. PhonerLite ist KEIN Open Source. Mehr Informationen zur Lizenz hier .

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz
    • Download


PhonerLite: Allgemein

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Allgemein

Der obere Teil des Hauptfensters unterteilt sich in 3 Bereiche:

  • links: Initiierung und Behandlung aktueller Rufe
  • mitte: Liste der aktuellen Rufe
  • rechts: Lautstärke und Sound-Geräte Einstellungen

Soundeinstellungen

Die beiden Knöpfe mit den Symbolen für Mikrofon und Lautsprecher zeigenden Status der Soundkarte an. Findet sich ein roten Kreuz über dem Symbol, so ist das jeweilige Gerät nicht aktiv.

Durch Anklicken mit der linken Maustaste kann der Status auch manuell geändert werden. Im unteren Bild sieht man, dass Aufnahme (Mikrofon) und Wiedergabe (Lautsprecher)aktiv sind, da ein aktueller Ruf besteht. Möchte man diesen Ruf kurzfristig stumm schalten, so genügt ein Klick auf den Mikrofon-Knopf - das rote Kreuz erscheint dann.

Auswahl der Soundkarte
Um bei Vorhandensein mehrerer Soundgeräte explizit eins auswählen zu können,kann man mit der rechten Maustaste diese Knöpfe anklicken. Es erscheint ein Kontextmenü, in welchem man die zu verwendete Soundkarte auswählen kann.

Die beiden Schieberegler steuern die Lautstärke für Aufnahme und Wiedergabe.Man kann über PhonerLite lediglich den zu verwendeten Soundtreiber auswählen,jedoch nicht den Anschluss der Soundkarte. Hierbei werden die Einstellungen des Soundmixers verwendet. Notfalls muss man hier also über des entsprechende Dienstprogramm den Anschluss auswählen.

Jabra GN9330e USB Jabra PRO 9470 HID-konforme Headsets von Jabra und Sennheiser werden nun direkt unterstützt. Die Rufannahme und das Auflegen per Knopfdruck sollte damit ebenso funktionieren.

Erscheinungsbild

Kontextmenü Erscheinungsbild Ein Rechtsklick auf die obere Buttonleiste lässt ein Kontextmenü erscheinen. Hier kann man das Erscheinungsbild jederzeit umschalten.

Aktuelle Rufe

Hier wird eine Liste aller aktiven Rufe angezeigt. Der Status der Verbindung wird über das vorangestellte Symbol verdeutlicht. Ein roter Pfeil signalisiert hierbei einen abgehenden Ruf - ein grüner Pfeil dagegen einen eingehenden Ruf.

Rufbehandlung

Hier finden sich Knöpfe zur Rufbehandlung, also zum Auf- und Abbauen einer Verbindung, Wahlwiederholung, Rufumleitung und Halten einer Verbindung.

Existieren mehrere Verbindungen, so beziehen sich die Aktionen zum Verbindungsabbau und Halten auf den markierten Ruf in der Rufliste.

Eine Rufübergabe (Transfer) erfolgt per Drag&Drop des aktiven Rufs auf den gehaltenen Ruf. Ein "Blind Transfer" erfolgt durch Drag&Drop des aktiven Rufes auf das Feld "Zielrufnummer", wo zuvor die neue Rufnummer schon eingegeben wurde.

Nachwahl

Wenn für einen ausgehenden Ruf automatisch nach der Rufannahme bestimmte DTMFs gesendet werden sollen, dann kann man dies als Teil der Rufnummer in PhonerLite verwenden, indem die DTMFs mit einem Semikolon getrennt am Ende der Rufnummer angegeben werden. Beispielsweise würde die Rufnummer "0123456789;1234" die Nummer "0123456789" anrufen und nach der Rufannahme eine Sekunde warten und die DTMFs "1", "2", "3" und "4" senden. Wenn Pausen zwischen den Zeichen sein sollen, so kann man ein Semikolon (";") für jeweils eine Sekunde auch mehrfach einfügen. Für eine kürzere Pause von 200 Millisekunden kann stattdessen ein Komma (",") verwendet werden. Beispiel: "0123456789;;1,2,3,4"

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: Logbuch

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Logbuch

In diesem Journal werden alle ein- und ausgehenden Rufe gespeichert. Die einzelnenEinträge können nicht verändert, aber gelöscht werden. Per Kontextmenü (rechter Mausklick) können zusätzliche Aktionen ausgelöst werden.

Durch Anklicken der Spaltenüberschriften kann nach dem jeweiligen Kriterium abwechselnd aufsteigend und absteigend sortiert werden.

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: Telefonbuch

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Telefonbuch

Das Telefonbuch ist dazu da, ein Verzeichnis mit Nummern und zugehörigem Namen zu speichern.

Nach einem rechtem Mausklick in den Telefonbuchbereich erscheint ein Kontextmenü,wo man neue Einträge anlegen und löschen kann. Klickt man mit der linken Maustaste etwas länger auf einen Eintrag, so kann man den Inhalt dazu verändern.

Um einen Eintrag aus dem Telefonbuch anzurufen, gibt es mehrere Varianten:

  • Doppelklick auf den gewünschten Eintrag
  • Rechter Mausklick auf diesen Eintrag und Auswahl von "Verbinden" aus dem Kontextmenü
  • Drag&Drop der Zeile in den Bereich "Aktuelle Anrufe"

Die letzte Spalte "Kommantar" ist ein reines Kommentarfeld, dort kann man beispielsweise so was wie "privat" oder "geschäftlich" reinschreiben. Es gibt eine Ausnahme: Ist eine URL (http://...) in diesem Feld hinterlegt, so wird bei einem Anruf von/zu dieser Telefonbuch-Nummer diese Web-Seite integriert dargestellt. Als Backend dient der Internet-Explorer dazu. Es können also HTTP- als auch HTTPS-Adressen angegeben werden. Ein Beispiel dafür könnte eine Video-URL (z.B. http://www.webcam-baden-baden.de/ltur.mjpg) einer Türsprecheinrichtung sein. Nach Rufende wird die Darstellung der HTML-Seite bzw. des Videos geschlossen.

Kurzwahltasten: Über das Optionen-Menü kann man die Kurzwahltasten ein- und ausblenden. Um eine Kurzwahltaste zu belegen, benutzt man Drag&Drop eines Eintrags aus dem Telefobuch auf eine solche Kurzwahltaste. Über das Kontextmenü (Rechtsklick auf eine Kurzwahltraste) kann man die Verknüpfung wieder aufheben.

Der Inhalt des Telefonbuchs wird in der Datei "phonebook.csv" gespeichert, welches eine reine Textdatei ist und somit mit jedem Editor verarbeitbar ist.

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: Nachrichten

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Nachrichten

Es können Kurznachrichten zu anderen SIP Gegenstellen gesendet und auch von diesem Empfangen werden. Dazu bedient sich PhonerLite an der Empfehlung nach SIP/SIMPLE .

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: Konfiguration

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Konfiguration

Es können mehrere Konfigurationen hinterlegt werden - sogenannte Profile. Lediglich eins der konfigurierten Profile kann aktiv sein. Das aktive Profil kann man über die Combobox in der Statuszeile auswählen. Durch Auswahl aus der Combobox auf der Konfigurationsseite kann man diese Profile verändern. Die Änderungen werden erst aktiv, wenn man den Speichern-Knopf gedrückt hat.

Server

Proxy/Registrar

Hier muss die Adresse des SIP-Servers eingetragen werden. Man unterscheidet zwischen zwei Arten von SIP-Servern:

  • Registrar: An diesem Server registriert man sich. Dadurch ist dem SIP-Server bekannt,unter welcher IP-Adresse der PC mit PhonerLite zu finden. Dafür benötigt man neben der Adresse des Registrars auch noch den eigenen Benutzernamen und das Passwort, mit welchem die Anmeldung erfolgt.
    Ohne eine erfolgreiche Anmeldung sind keine eingehenden Rufe möglich - man kann also nicht angerufen werden.
  • Proxy: Über diesen Server werden abgehende Verbindungen aufgebaut. Der Proxy-Server hat die Aufgabe, die Zielrufnummer aufzulösen und eventuell den Ruf an ein Gateway weiterzuleiten,sodass der Ruf ins öffentliche Telefonnetz geroutet werden kann.

Die meisten VoIP-Provider verwenden für den Registrar und den Proxy die gleiche Adresse, weshalb man in PhonerLite auch nur eine Adresse eingeben kann. Die Adresse kann einerseits ein Name (z.B. "sipgate.de") sein, oder eine IP Adresse (z.B. "217.10.79.9"). Der Default Port für SIP lautet 5060. Sollte der Proxy bzw. Registrar einen davon abweichenden Port verwenden, so kann man diesen mit einem Doppelpunkt anhängen (z.B. sipgate.de:5060").

Über die Option "Register" kann man steuern, ob eine Anmeldung erfolgen soll oder nicht.

STUN Server

Da ein PC üblicherweise eine private IP-Adresse besitzt, muss die öffentliche IP-Adresse ermittelt werden. Hierzu benutzt PhonerLite STUN und man benötigt deshalb eine Adresse des STUN Servers.

Selbst die Verwendung von STUN garantiert jedoch nicht immer eine reibungslose Kommunikation. Restriktive Firewalls muss man im Fehlerfall also so konfigurieren, dass auf den UDP -Ports 5060 und 5062 eine Portweiterleitung zu dem PC mit PhonerLite erfolgt.

Realm/Domain

Bei der Wahl einer Telefonnummer muss diese in ein gültiges Format gebracht werden. Damit der Benutzer bei der gewünschten Telefonnummer nicht selbst eine entsprechende Darstellung eingeben muss, kann PhonerLite diese selbständig ergänzen. Per Default wird einfach die Proxy/Registrar-Adresse benutzt. Weicht diese jedoch vom gewünschten Format ab, so muss man die Domain hier eintragen.

Dazu ein Beispiel: Die Adresse des Proxy/Registrars lautet "sip.domain.com". Die gerufenen Adressen müssen jedoch die Domain "domain.com" benutzen - man beachte die fehlende Subdomäne "sip".Einegültige Zieladresse würde also "49891234567@domain.com" lauten. Für diesen Fall sollte man "domain.com" in dieses Feld eintragen.

Die Angabe ist jedoch optional, da Zieladressen auch komplett vom Benutzer eingegeben werden können.

Benutzer

Benutzername

Über den Benutzernamen erfolgt die Identifizierung. Unter diesem Namen ist man bei dem SIP Proxy/Registrar registriert. Dieser Name wird meistens von dem VoIP-Provider vergeben. Bei der Übertragung der Nachrichten wird dieser Name im Klartext (also unverschlüsselt) gesendet.

Passwort

Mit einem Kennwort soll sichergestellt werden, dass der Benutzername auch zurecht benutzt wird. Dieses Kennwort wird nicht im Klartext übertragen, sondern per MD5 lediglich in verschlüsselter Form benutzt.

Die gespeicherten Profileinstellungen (sipper.ini) beinhalten die Einstellungen inklusive der verschlüsselten Passwörter. Man sollte diese Datei nicht einfach an Dritte weitergeben, weil die damit den Account einfach benutzen können.

Angezeigter Name

Hier kann optional ein Name oder eine sonstige Bezeichnung angegeben werden. Zusätzlich zur eigenen Adresse kann man somit eine Zusatzinformation mitgeben, normalerweise den eigenen Namen.

Netzwerk

Lokaler Port

Den lokalen Signalisierungsport kann man hier konfigurieren. Für die Sprachübertragung (lokaler RTP -Port) wird immer der Port mit dem Wert des Signalisierungsport erhöht um 2 verwendet - per Default also 5062. Für jeden zusätzlichen Ruf erhöht sich der Wert wiederum um 2.

Ist ein gewünschter Port schon vergeben (z.B. durch eine andere Applikation), so wird ein vom System vergebener Port verwendet.

bevorzugte Verbindungsart

Eingehende Verbindungen sind immer über UDP, TCP und TLS möglich. Für ausgehende Verbindungen (Registrierung und Rufaufbau) werden über die hier konfigurierte Verbindungsart aufgebaut.

Multicast DNS

Ist diese Option gesetzt, so finden sich mehrere PhonerLite Instanzen im Netzwerk automatisch. Es erscheint dann eine neue Registerseite mit dem Namen "Nachbarn". Die dort befindlichen Einträge können per Drag&Drop angerufen werden.

UPnP NAT

Mittels UPnP kann PhonerLite die öffentliche IP-Adresse des Routers ermitteln und automatisch eine Portweiterleitung im Router einrichten. Dazu muss jedoch der Router UPnP und die Steuerung mittels UPnP unterstützen.

Wenn die Steuerung per UPnP vom Router unterstützt wird, ist dieses Verfahren gegenüber STUN vorzuziehen.

IPv6

Ab Windows Vista ist IPv6 als Alternative zu IPv4 nutzbar. Die komplette Infrastruktur muss dann jedoch ebenfalls IPv6 nutzen. Ein Mischbetrieb von IPv4 und IPv6 ist in PhonerLite nicht nutzbar!

Codecs

Ein Codec ist eigentlich ein Kunstwort aus Coder und Decoder, also einem Kodierer und Dekodierer.

In diesem Fenster können die einzelnen Codecs deaktiviert und in ihrer Priorität geändert werden. Der bevorzugte Codec sollte in der Liste ganz oben stehen. Ob der bevorzugte Codec dann auch tatsächlich verwendet wird, hängt davon ab, ob die Gegenstelle auch diesen Codec unterstützt.

Die angegebenen Datenraten sind Netto-Werte. In der Praxis wird eine höhere Bandbreite benötigt, da die eigentlichen Sprachdaten noch zusätzlich in einem RTP Paket und diese dann wieder in einem UDP Paket verpackt sind. Dann kommt noch ein IP - und meistens noch ein PPPoE Paket herum. Die Bruttodatenrate eines G.711-Codecs beträgt somit beispielsweise ca. 80 kBit/s. Für eine Modem-, ISDN- oder DSL-Light-Verbindung reicht das dann nicht mehr aus! In diesem Fall sollte man die G.711-Codecs deaktivieren.

Hier die unterstützen Codecs von PhonerLite:

  • G.711 A-Law
  • G.711 µ-Law
  • G.726 -16, -24, -32, -40
  • G.722 (Wideband)
  • GSM
  • iLBC
  • Speex und Speex-Wideband
  • Opus
  • G.729
  • LPCM (L16/44100, L16/16000)

Echo-Unterdrückung

Unter der Echo-Cancellation versteht man die Analyse der gesendeten Daten und das Herausfiltern der darin befindlichen Empfangsdaten. Durch Aktivieren dieser Option kann man also Verhindern, dass man über das Mikrofon wieder etwas aufnimmt, was aus den Lautsprechern ertönt.

Stilleerkennung

Unter der Stilleerkennung versteht man die Analyse der vom Mikrofon aufgenommenen Daten (was also gesendet werden soll). Enthalten diese Daten keine hörbaren Nutzdaten, also Stille, so kann dieses möglicherweise korrekt erkannt werden.

Es stehen folgende Optionen zur Auswahl:

  • keine Stilleerkennung
    Hierbei ist erfolgt keinerlei Versuch Stille zu erkennen. Default
  • Stille ausblenden
    Wird Stille erkannt, so werden diese Daten komplett ausgeblendet, d.h. auf die Lautstärke Null gesetzt. Die Daten werden trotzdem gesendet. Jegliches Umgebungsgeräusch wird somit gelöscht, was bei der Gegenstelle manchmal zur Irritationen führt. Ein Echoeffekt kann jedoch durch diese Maßnahme minimiert werden.
  • Stille nichts schicken
    Im Grunde ist alles gleich wie beim vorherigen Punkt, jedoch wird im Stille-Fall nichts gesendet. Das spart als zusätzlichen Nebeneffekt auch Transfervolumen.

Eine optimale Einstellung sollte jeder selber herausfinden.

SRTP

Sollen die Sprachdaten verschlüsselt werden, so kann die Option SRTP aktiviert werden. Damit der Schlüsselaustausch nicht im Klartext über die Leitung geht, macht SRTP nur bei Verwendung von TLS Sinn.

Die Gegenstelle muss ebenfalls SRTP unterstützen. Getestet wurde das bisher erfolgreich beim direkten IP-Ruf zu einem Grandstream GXP2000 als auch über den VoIP-Provider dus.net .

ZRTP

Um bei einer IP-zu-IP-Verbindung eine Ende-zu-Ende Verschlüsselung der Audio-Daten zu ermöglichen, kann bei kompatiblen Gegenstellen der Schlüsselaustausch auch ohne TLS erfolgen.

Zertifikate

Für die verschlüsselte Übertragung per TLS werden Zertifikate benötigt.Bei der Verbindung zu einem Server hin, kann dieser ein Client-Zertifikat anfordern. Dieses Client-Zertifikat identifiziert den Benutzer von PhonerLite gegenüber dem Server. Ein solches Client-Zertifikat kann über die "..." Schaltfläche geladen,oder der Dateiname direkt eingegeben werden. Wird kein Client-Zertifikat konfiguriert, so wird ein fest eingebautes Zertifikat verwendet.

Mächte man eine sogenannte Peer-to-Peer Verbindung ermöglichen, kann es auch sein, dass sich eine Gegenstellemit der eigenen PhonerLite-Instanz verbindet. In diesem Fall wird ein Server-Zertifikat benötigt.

Die angegebenen Zertifikat-Dateien müssen sowohl einen Schlüssel und das Zertifikat selbst beinhalten. Der Dateiaufbau ist folgender:

-----BEGIN RSA PRIVATE KEY-----
[...]
-----END RSA PRIVATE KEY-----
-----BEGIN CERTIFICATE-----
[...]
-----END CERTIFICATE-----

Konfigurationsdateien

Der Speicherort der Konfigurationsdateien hängt davon ab, ob das Programm-Verzeichnis Schreibrechte besitzt oder nicht. Sollten volle Schreibrechte vorhanden sein, befinden sich die Konfigurationsdateien mit im Programmverzeichnis. Sollten keine Schreibrechte vorhanden sein (z.B. für C:\Program Files (x86)\PhonerLite), befinden sich diese Dateien hier: %APPDATA%\PhonerLite. Folgende Dateien werden vom Programm selbst verwaltet:

  • PhonerLite.ini: globale Einstellungen (Fensterpositionen, verwendete Soundkarte, ...)
  • sipper.ini: SIP-Profil spezifische Einstellungen (Zugangsdaten)
  • logbook.csv: Logbuch
  • phonebook.csv: Telefonbuch

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: Rufumleitung

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Rufumleitung

Eingehende Rufe können an einen anderen Anschluss weitergeleitet werden. Pro Profil kann ein Weiterleitungsziel konfiguriert werden.

Damit diese Art der Weiterleitung funktioniert, muss PhonerLite gestartet und registriert sein.

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: Statistik

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Statistik

Auf dieser Seite können Statistiken über den den aktuellen Ruf angeschaut werden. Ist kein Ruf aktiv, sind alle Angaben leer.

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: CLI

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

CLI - Command Line Interface

Eine Art Script-Steuerung kann man im Optionen-Menü aktivieren: CLI Zugang

Wenn dies aktiviert ist, kann man mit einem Telnet-Client sich zu PhonerLite an den Port 50600 verbinden:

          telnet localhost 50600

Man kann Kommandos wie "Help" eingeben oder ein Script aus einer Datei laden. Es gibt einige Einschränkungen wie fehlende "If"-Verschachtelung oder fehldene Schleifen. Letzteres kann man durch Laden einer Script-Datei aber umgehen - alle aktuellen Stati und Kommandos werden dadurch zurückgesetzt.

Das "Wait" und "If"-Kommando kann mehrere Bedingungen prüfen, welche kommasepariert angegeben werden. Es gilt hierbei die OR-Verknüpfung.

Examples

Dieses Beispiel zeigt, wie man einen ausgehenden Ruf aufbaut und eine Wave-Datei abspielen lässt, sobald der Ruf verbunden ist. Nach dem Abspielen wird der Ruf beendet:

If HasCall
  Print Stop script due existing other call
  Stop
EndIf
SetNumber 0123456789
HookOff
Wait 5,HasCall
If !HasCall
  Print Stop script due no call could be created
  HookOn
  Stop
EndIf
Print Waiting for call is beeing answered within 30 seconds
Wait 30,!HasCall,StateIsActive
if !StateIsActive
  Print Call not answered within 30 seconds
  HookOn
  Stop
EndIf
Print Waiting 2 seconds before playing wave file
Wait 2
Wave announcement.wav
Print Waiting for wave file is being played
Wait !StateIsActive,WavePlayed
Wait 1
HookOn

Man kann ein solches Script nicht in dieser formatierten Art manuell eingeben, da das "Wait"-Kommando die weitere Eingabe blockiert. Aus diesem Grund sollte ein Script in eine Datei gespeichertwerden (z.B. "script.txt") und durch folgendes Kommando geladen werden: "load script.txt".

Alternativ kann man obiges Script auch in einer Zeile darstellen, die Zeilen werden durch "&" getrennt:

If HasCall & Print Stop script due existing other call & Stop & EndIf & SetNumber 0123456789 & HookOff & Wait 5,HasCall & If !HasCall & Print Stop script due no call could be created & HookOn & Stop & EndIf & Print Waiting for call is beeing answered within 30 seconds & Wait 30,!HasCall,StateIsActive & if !StateIsActive & Print Call not answered within 30 seconds & HookOn & Stop & EndIf & Print Waiting 2 seconds before playing wave file & Wait 2 & Wave announcement.wav & Print Waiting for wave file is being played & Wait !StateIsActive,WavePlayed & Wait 1 & HookOn

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: Features

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Features

Protokolle

  • SIP
  • UDP , TCP
  • STUN

IP

  • IPv4
  • IPv6

Sicherheit/Verschlüsselung

  • TLS
  • SRTP
  • ZRTP

Codecs

  • G.711 A-Law
  • G.711 µ-Law
  • G.726 -16, -24, -32, -40
  • G.722
  • GSM
  • iLBC
  • Speex
  • Opus

DTMF

  • RTP Payload
  • INFO

Sprachen

  • Deutsch
  • Englisch
  • Spanisch
  • Portugiesisch
  • Russisch
  • Arabisch
  • Tschechisch
  • Polnisch
  • Türkisch
  • Italienisch

RFCs

  • RFC 2327: SDP: Session Description Protocol
  • RFC 2833: RTP Payload for DTMF Digits, Telephony Tones and Telephony Signals
  • RFC 2976: The SIP INFO Method
  • RFC 3261: SIP: Session Initiation Protocol
  • RFC 3262: Reliability of Provisional Responses in the Session Initiation Protocol (SIP)
  • RFC 3264: An Offer/Answer Model with the Session Description Protocol (SDP)
  • RFC 3265: Session Initiation Protocol (SIP)-Specific Event Notification
  • RFC 3311: The Session Initiation Protocol (SIP) UPDATE Method
  • RFC 3323: A Privacy Mechanism for the Session Initiation Protocol (SIP)
  • RFC 3325: Private Extensions to the Session Initiation Protocol (SIP) for Asserted Identity within Trusted Networks
  • RFC 3515: The Session Initiation Protocol (SIP) Refer Method
  • RFC 3581: An Extension to the Session Initiation Protocol (SIP) for Symmetric Response Routing
  • RFC 3605: Real Time Control Protocol (RTCP) attribute in Session Description Protocol (SDP)
  • RFC 3711: The Secure Real-time Transport Protocol (SRTP)
  • RFC 3842: A Message Summary and Message Waiting Indication Event Package for the Session Initiation Protocol (SIP)
  • RFC 3891: The Session Initiation Protocol (SIP) "Replaces" Header
  • RFC 3892: The Session Initiation Protocol (SIP) Referred-By Mechanism
  • RFC 4028: Session Timers in the Session Initiation Protocol (SIP)
  • RFC 4235: An INVITE-Initiated Dialog Event Package for the Session Initiation Protocol (SIP)
  • RFC 4568: Session Description Protocol (SDP) Security Descriptions for Media Streams
  • RFC 4916: Connected Identity in the Session Initiation Protocol (SIP)
  • RFC 5389: Session Traversal Utilities for NAT (STUN)
  • RFC 5626: Managing Client-Initiated Connections in the Session Initiation Protocol (SIP)
  • RFC 5763: Framework for Establishing a Secure Real-time Transport Protocol (SRTP)
  • RFC 5761: Multiplexing RTP Data and Control Packets on a Single Port
  • RFC 5806: Diversion Indication in SIP
  • RFC 6189: ZRTP: Media Path Key Agreement for Unicast Secure RTP
  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: Lizenz

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Lizenz

Wenn nicht anders ausgewiesen, dann stehen die Dokumentation und die Software aus dem PhonerLite Paket unter dem Copyright von Heiko Sommerfeldt.

Copyright (C) 2019 Heiko Sommerfeldt. Alle Rechte vorbehalten.

Diese Software wird zur Verfügung gestellt, so wie sie ist, ohne ausdrückliche oder implizite Garantie.
Keinesfalls ist der Autor verantwortlich für etwaigen Schaden, der durch die Verwendung dieser Software auftritt.

Es wird allen Nutzern des Programms bewilligt, diese Software für jeden möglichen Zweck einzusetzen, kommerzielle Nutzung inbegriffen.
Veränderungen am Paketumfang und Weitergabe wird erlaubt, solange folgende Bedingungen erfüllt werden:

  1. Jegliche Weitergabe des gesamten Pakets, oder Teile daraus, muss alle Angaben obiger Copyright Nennung und die Webadresse beinhalten.
  2. Die Herkunft der Software darf nicht falsch dargestellt werden, es darf also nicht fälschlicherweise behauptet werden, der Autor dieser Software zu sein.
  3. Veränderte Versionen müssen als solche deklariert und nicht als Originalsoftware dargestellt werden.
  4. Jegliche Weitergabe des gesamten Pakets, oder Teile daraus, hat unentgeltlich zuerfolgen. Eine kommerzielle Weitergabe ist nicht ausgeschlossen, bedarf jedoch einer Rückfrage beim Autor.

Copyright der benutzten Bibliotheken:

  • oSIP: (C) 2002 Aymeric MOIZARD, http://www.osip.org
  • iLBC: (c) 2000-2003 The iLBCfreeware.org Project, http://www.ilbcfreeware.org
  • Speex: © 2002-2003, Jean-Marc Valin/Xiph.Org Foundation, http://www.speex.org
  • libSRTP: (c) 2001-2005 Cisco Systems, Inc., http://srtp.sourceforge.net/srtp.html
  • OpenSSL: Copyright (c) 1998-2007 The OpenSSL Project, http://www.openssl.org/
  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite English

  • Easy to use VoIP softphone with profile and contact management
  • German German English English Russian Russian
  • Index
  • General
  • Configuration
  • Download
  • Contact

What is PhonerLite?

PhonerLite is a clearly arranged application for Windows. PhonerLite enables your PC to use it for Internet telephony (VoIP , Voice over IP ). Pre-conditions are a full-duplex sound card , a microphone and speakers (alternatively a headset), an Internet connection and an account from a provider supporting the protocol SIP . PhonerLite supports several SIP profiles, each configurable independently.

PhonerLite supports state of the art encryption methods like TLS, SRTP and ZRTP.

Why is "PhonerLite" the right name?

  • Phoner: There is an application called Phoner , with that PhonerLite shares common code and the file "sipper.dll". All VoIP specific configurations are the same and can be exchanged between Phoner and PhonerLite without any transformations. If Phoner and PhonerLite are installed in the same directory, they use the same DLL and configuration data (sipper.ini). Basically PhonerLite uses only a different GUI than Phoner.
  • Lite: Like in Coke light the name affix suggests a light version of the original product. PhonerLite doesn't save any calories but resources - in this special case space and memory requirements.Usability is much easier than for Phoner. This advantage got some disadvantages: there is no answering machine and no support for TTS .

Is PhonerLite free of charge?

YES! PhonerLite is freeware. PhonerLite can be used, copied, and offered for download again without any fees in private and business environments. But PhonerLite is no open source. More information concerning license see here .

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: General

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

general

The upper part of the main window is divided into 3 parts:

  • left: Initiating and manipulation of calls
  • center: List of actual calls
  • right: Volume and sound device settings

sound device settings

Both buttons with the symbols for microphone and speaker show the status of the sound device. If there is a red cross on the symbol, the device is not active.

Clicking with left mouse button the status can be changed manually. In the picture below you can see that recording (microphone) and playback (speaker) are active because there is an active call. If you want to mute, so click once at the microphone button - the red cross should be visible then.

device selection
If more than one sound device is present in the system, you can chose the right one by right clicking on these buttons. A context menu appears where all devices are listed. You can select the device that should be used.

Both sliders control the volume of recording and playback. Within PhonerLite you only can select sound devices but no ports on that devices. For this you need still the sound mixer, which is part of the Windows distribution..

Jabra GN9330e USB Jabra PRO 9470 HID compatible headsets by Jabra and Sennheiser are supported now more directly. Incoming calls can be accepted and disconnected by pressing the button on the headset.

appearance

Context menu appearance Right click on the upper button bar will show a context menu where you can change the appearance at any time.

active calls

A list of active calls is shown here. The status of the connection is visualized by a symbol in front of each entry in the list. A red arrow in this symbol means an outgoing call - a green arrow an incoming one.

call handling

Here are the buttons for call handling, that are: call initiating, disconnect, redial, forwarding and hold..

If there are more than one connection, above actions are related to the selected call in the call list.

A call transfer is initiated by drag&drop operation of the active call onto the held call. A "blind transfer" is done by drag&drop in the field "Destination number" where the new number is entered previously.

Dial after

If you want to call a number and some DTMFs should be send after call establishment, you can do it in PhonerLite by appending a semicolon and DTMFs at the end of the phone number. Example: 0123456789;1234

If you need some pause after call stablishment or between the DTMFs you can insert multiple semicolon (";") - each semicolon means one second pause. A comma (",") is for a shorter pause of 200 milliseconds. Example: 012345679;;1,2,3,4

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: log book

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

log book

In this journal all incoming and outgoing calls are saved. The single entries can'tbe modified but deleted. From the context menu (right click) additional actions can be initiated.

By clicking at the column headers you can sort the entries ascending and descending alternately.

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: phone book

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

phone book

The pone book is a directory of numbers and associated names saved permanently.

Clicking the right mouse button a context menu appears. You can create and deletethere entries. Clicking a bit longer with the left mouse button, you enter the edit mode and can change the selected text..

There are several methods to dial a number from the phone book:

  • double click the entry
  • right click the entry and chose "connect" from the context menu
  • Drag&Drop the entry into the area called "actual calls"

The last column "comment" is a simple comment field - you can put there text like "private" or "busy". There is one exception: If you put in this field an URL (http://...), a web site will be displayed for a call from/to this phone book number. The Internet-Explorer is used as backend. HTTP and HTTPS addresses are supported. One scenario would be video based door line support (e.g. a video URL like http://www.webcam-baden-baden.de/ltur.mjpg). After call termination the display of the web site or video will be closed.

Speed dial buttons: Via the options menu you can show and hide that speed dial buttons. Using drag&drop of an entry in phonebook onto such button you can assign the value/number. In the context menu of such button (right click) you can delete that assignment.

The content of the phone book is saved in the file called "phonebook.csv". It contains pure text, so it can be edited with any editor.

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: messages

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

messages

You can send short text messages to other SIP users and can receive such messages from them. PhonerLite uses SIP/SIMPLE for this.

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: configuration

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

configuration

There can be more than one configuration - so called profiles. But only one of these profiles can be active. The active profile can be chosen with the combo box at the status bar. If you want to create, modify or delete a profile, you have to activate the configuration page and chose there in the combo box the profile. Any changes to a profile get active only after pressing the save button.

Server

Proxy/Registrar

Enter here the address of your SIP server. There are two kinds of SIP servers:

  • Registrar: To this servers registrations are sent. So the SIP server knows your IP address of the PC running PhonerLite. You need the address of the registrar, a username and password.
    Without registration you won't get any incoming calls.
  • Proxy: To this server all outgoing calls will be routed. The proxy servers task is to analyze the called destination address so it maybe route the call to a gateway for public phone calls.

Most VoIP providers are using the same address for registrar and proxy. Therefore only one address is configurable in PhonerLite. The address might be a name (e.g. "sipgate.de") or an IP address (e.g. "217.10.79.9"). The default port for SIP signaling is 5060. If the proxy/registrar uses a different port, you can concatenate it by a leading colon (e.g. "sipgate.de:5060").

Using the checkbox "Register" you can select whether to register or not.

STUN server

Normally a PC got a private IP address. If the destination is out of this private network, your public IP address have to be within the SIP messages transmitted to the server. For retrieving this public IP address STUN is used and therefore a STUN server must be configured.

Even using STUN there is no guarantee for a functional communication. In case of communication errors such restrictive firewalls must be configured for passing messages using UDP ports 5060 and 5062 to the PC running PhonerLite.

Realm/Domain

SIP uses a different address format than in public switched telephone networks.To enable the input of normal phone numbers, PhonerLite needs some information for extend this number to the right SIP format . Default is using the proxy/registrar address. If this address differs from the needed domain you have to enter this domain here.

Example: The address of the proxy/registrar is "sip.domain.com". But called addresses must use the domain "domain.com" - see, there is a missing sub domain "sip". A valid destination address would be "49891234567@domain.com". For this case you have to enter "domain.com" in to this field.

There is no must be for this domain, because users can dial complete SIP addresses manually too.

User

Username

The username is used for authentication . With this username you have to be registered at the SIP proxy/registrar. You get this name from your VoIP provider. Within message exchange this name is transmitted unencrypted.

Password

Using this password the username can be validated by the SIP server. The password is encrypted by MD5 within the messages.

All saved profiles (sipper.ini) contain all settings including encrypted passwords.Don't give this file to other people, because they can use your accounts without modifications!

Displayed name

You can enter here any text you want, but normally your real name should be here.

Network

Local port

The local signaling port you can choose here. For speech transmission (RTP) the port with a value of additional 2 will be used. So if the signaling port is 5060 the RTP port will be 5062. Any further call use the port increased by 2 again.

If a configured port is used by a another application, a port given by the system is used then.

Preferred connection type

Incoming connections are always possible using UDP, TCP and TLS. For outgoing connections (registration and call initiation) will use the preferred connection type.

Multicast DNS

If this option is enabled, several PhonerLite instances in the same LAN will find each other automatically. A new index page with the name "Neighbours" will be shown. Using drag&drop with that entries to the call list will initiate a direct connection to that instance.

UPnP NAT

Via UPnP PhonerLite can retrieve the public IP address of the router and can set a port forwarding automatically. The router has to support UPnP and the control via UPnP.

If UPnP control is supported by the router, this procedure is preferred against STUN.

IPv6

With Windows Vista and newer versions IPv6 is usable as an alternative to IPv4 . The complete infrastructure has to support IPv6 too. IPv4 and IPv6 is not usable at the same time in PhonerLite!

Codecs

A codec is the short word for "coder and decoder"..

In this window you can disable individual codecs and change their priority. The most preferred codec should be on top of the list. If this preferred codec is used belongs of the counterpart - if it supports this codec too.

The shown data rates are net values. In practice these values are much higher because of the encapsulation of speech data in RTP , UDP and finally in IP packets.The gross data rate for a G.711 codec is about 80 kBits/s. This is too much for modem and ISDN dial-up connections! But if such connection is used, these codecs should be disabled here.

Following codecs are supported by PhonerLite:

  • G.711 A-Law
  • G.711 µ-Law
  • G.726 -16, -24, -32, -40
  • G.722 (Wideband)
  • GSM
  • iLBC
  • Speex and Speex-Wideband
  • Opus
  • G.729
  • LPCM (L16/44100, L16/16000)

Echo Cancellation

Echo Cancellation means analyzing of data to be sent and the filtering of containing received data. By activating this option you can avoid that you your microphone records data from the speakers.

silence detection

"silence detection" means the analysis of recorded data from the microphone (what should be sent). If this data doesn't contain any audible voice activities, this can be detected.

There are three options for this:

  • no silence detection
    There is no analysis done at all. Default
  • blank silence
    If silence is detected, this data will be blanked out. This means the volume is set to zero. The data will be sent anyway. The disadvantage is that there are no environment noises in silence periods. Some people receiving such silence often ask, if you are still there. The advantage is minimized echo effect.
  • silence suppress
    Its nearly the same as "blank silence", but there will be sent nothing in case of silence. This reduces transfer volume.

Everybody has to find out the optimal setting by himself.

SRTP

If speech data should be encrypted, you can activate the option SRTP . To avoid key exchange in clear text, SRTP should only be used in conjunction with TLS..

The peer (phone or provider) must support SRTP too. The actual implementation is tested against Grandstream GXP2000 and the German VoIP provider dus.net .

ZRTP

To enable end-to-end encryption of audio data for pure IP-to-IP calls, key exchange can be used without TLS.

Certificates

Certificates are needed by secured connections using TLS . For connections to a server, this server may request a client certificate. Such client certificate authorizes the user of PhonerLite to the server. You can load such certificate by pressing the "..." button or by typing the filename directly. If no client certificate is configured a built in certificate is used.

If you want to enable peer-to-peer connections, you need to configure a server certificate.

The configured certificate files must include a key and the certificate itself. The files should like like:

-----BEGIN RSA PRIVATE KEY-----
[...]
-----END RSA PRIVATE KEY-----
-----BEGIN CERTIFICATE-----
[...]
-----END CERTIFICATE-----

Configuration files

The location of the configuration files depend on the write access permissions. If the program folder has full write access permissions, this folder is used for configigurations files too, else this folder is used: %APPDATA%\PhonerLite. Following files will be created and handled by the application:

  • PhonerLite.ini: global configuration (window position, used sound devices, ...)
  • sipper.ini: SIP profile specific configuations (account informations)
  • logbook.csv: log book
  • phonebook.csv: phone book

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: forwarding

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

forwarding

Incoming calls can be forwarded to another destination. Per profile can be configured one forwarded-to destination.

PhonerLite must be active/running for this kind of forwarding.

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: statistic

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

statistic

At this page call statistics can be viewed. If no call is active there will be all fields empty.

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: CLI

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

CLI - Command Line Interface

You can enable some kind of scripting via options menu: CLI access

If you have activated that you can connect to Port 50600 using a telnet client:

    telnet localhost 50600

You can enter commands like "help" or you can load a script from file. There some limitations like no nested "If" statements or no loop support. But you can load a script file - all current states and remaining commands are resetted.

The "Wait" and "If" command can check multiple conditions. They are comma separated and use a logical OR combination.

Examples

This example shows, how to initatiate an outgoing call and play a wave file when the call is established and after the file is played the call will be terminated:

If HasCall
  Print Stop script due existing other call
  Stop
EndIf
SetNumber 0123456789
HookOff
Wait 5,HasCall
If !HasCall
  Print Stop script due no call could be created
  HookOn
  Stop
EndIf
Print Waiting for call is beeing answered within 30 seconds
Wait 30,!HasCall,StateIsActive
if !StateIsActive
  Print Call not answered within 30 seconds
  HookOn
  Stop
EndIf
Print Waiting 2 seconds before playing wave file
Wait 2
Wave announcement.wav
Print Waiting for wave file is being played
Wait !StateIsActive,WavePlayed
Wait 1
HookOn

You can't enter such script manually in that formatted way, because the "Wait" command may hide the prompt - so you can't enter further commands. You should save a script in a file (e.g. "script.txt") and enter the following command at the prompt: "load script.txt".

Alternativ kann man obiges Script auch in einer Zeile darstellen, die Zeilen werden durch "&" getrennt:

If HasCall & Print Stop script due existing other call & Stop & EndIf & SetNumber 0123456789 & HookOff & Wait 5,HasCall & If !HasCall & Print Stop script due no call could be created & HookOn & Stop & EndIf & Print Waiting for call is beeing answered within 30 seconds & Wait 30,!HasCall,StateIsActive & if !StateIsActive & Print Call not answered within 30 seconds & HookOn & Stop & EndIf & Print Waiting 2 seconds before playing wave file & Wait 2 & Wave announcement.wav & Print Waiting for wave file is being played & Wait !StateIsActive,WavePlayed & Wait 1 & HookOn

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: features

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

features

protocols

  • SIP
  • UDP , TCP , TLS
  • STUN

IP

  • IPv4
  • IPv6

Security/Encryption

  • TLS
  • SRTP
  • ZRTP

Codecs

  • G.711 A-Law
  • G.711 µ-Law
  • G.726 -16, -24, -32, -40
  • G.722
  • GSM
  • iLBC
  • Speex and Speex-WB
  • Opus

DTMF

  • RTP Payload

Languages

  • German
  • English
  • Spanish
  • Portuguese
  • Russian
  • Arabic
  • Czech
  • Polish
  • Turkish
  • Italian

RFCs

  • RFC 2327: SDP: Session Description Protocol
  • RFC 2833: RTP Payload for DTMF Digits, Telephony Tones and Telephony Signals
  • RFC 2976: The SIP INFO Method
  • RFC 3261: SIP: Session Initiation Protocol
  • RFC 3262: Reliability of Provisional Responses in the Session Initiation Protocol (SIP)
  • RFC 3264: An Offer/Answer Model with the Session Description Protocol (SDP)
  • RFC 3265: Session Initiation Protocol (SIP)-Specific Event Notification
  • RFC 3311: The Session Initiation Protocol (SIP) UPDATE Method
  • RFC 3323: A Privacy Mechanism for the Session Initiation Protocol (SIP)
  • RFC 3325: Private Extensions to the Session Initiation Protocol (SIP) for Asserted Identity within Trusted Networks
  • RFC 3515: The Session Initiation Protocol (SIP) Refer Method
  • RFC 3581: An Extension to the Session Initiation Protocol (SIP) for Symmetric Response Routing
  • RFC 3605: Real Time Control Protocol (RTCP) attribute in Session Description Protocol (SDP)
  • RFC 3711: The Secure Real-time Transport Protocol (SRTP)
  • RFC 3842: A Message Summary and Message Waiting Indication Event Package for the Session Initiation Protocol (SIP)
  • RFC 3891: The Session Initiation Protocol (SIP) "Replaces" Header
  • RFC 3892: The Session Initiation Protocol (SIP) Referred-By Mechanism
  • RFC 4028: Session Timers in the Session Initiation Protocol (SIP)
  • RFC 4235: An INVITE-Initiated Dialog Event Package for the Session Initiation Protocol (SIP)
  • RFC 4568: Session Description Protocol (SDP) Security Descriptions for Media Streams
  • RFC 4916: Connected Identity in the Session Initiation Protocol (SIP)
  • RFC 5389: Session Traversal Utilities for NAT (STUN)
  • RFC 5626: Managing Client-Initiated Connections in the Session Initiation Protocol (SIP)
  • RFC 5763: Framework for Establishing a Secure Real-time Transport Protocol (SRTP)
  • RFC 5761: Multiplexing RTP Data and Control Packets on a Single Port
  • RFC 5806: Diversion Indication in SIP
  • RFC 6189: ZRTP: Media Path Key Agreement for Unicast Secure RTP
  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


Phonerlite: license

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

license

Except where otherwise noted, all of the documentation and software included in the PhonerLite package is copyrighted by Heiko Sommerfeldt.

Copyright (C) 2019 Heiko Sommerfeldt. All rights reserved.

This software is provided "as-is", without any express or implied warranty.
In no event shall the author be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter and distribute it, provided that the following conditions are met:

  1. All distributions of the whole package or parts of it must retain all occurrences of the above copyright notice and web site addresses.
  2. The origin of this software must not be misrepresented; you must not claim that you wrote the original software.
  3. Modified versions must be plainly marked as such, and must not be misrepresented as being the original software.
  4. All distributions of the whole package or parts of it must keep free of charge. Commercial distribution needs further inquiry to the author.

Copyright of used libraries:

  • oSIP: (C) 2002 Aymeric MOIZARD, http://www.osip.org
  • iLBC: (c) 2000-2003 The iLBCfreeware.org Project, http://www.ilbcfreeware.org
  • Speex: © 2002-2003, Jean-Marc Valin/Xiph.Org Foundation, http://www.speex.org
  • libSRTP: (c) 2001-2005 Cisco Systems, Inc., http://srtp.sourceforge.net/srtp.html
  • OpenSSL: Copyright (c) 1998-2007 The OpenSSL Project, http://www.openssl.org/
  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: Codecs

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Codecs

Ein Codec ist eigentlich ein Kunstwort aus Coder und Decoder, also einem Kodierer und Dekodierer.

In diesem Fenster können die einzelnen Codecs deaktiviert und in ihrer Prioritätgeändert werden. Der bevorzugte Codec sollte in der Liste ganz oben stehen.Ob der bevorzugte Codec dann auch tatsächlich verwendet wird, hängt davon ab, ob die Gegenstelle auch diesen Codec unterstützt.

Die angegebenen Datenraten sind Netto-Werte. In der Praxis wird eine höhereBandbreite benötigt, da die eigentlichen Sprachdaten noch zusätzlich in einem RTP Paket und diese dann wieder in einem UDP Paket verpackt sind. Dann kommt noch ein IP - und meistensnoch ein PPPoE Paket herum. Die Bruttodatenrate eines G.711-Codecs beträgtsomit beispielsweise ca. 80 kBit/s. Für eine Modem-, ISDN- oder DSL-Light-Verbindung reicht das dann nicht mehr aus! In diesem Fall sollte man die G.711-Codecs deaktivieren.

Hier die unterstützen Codecs von PhonerLite:

  • G.711 A-Law
  • G.711 µ-Law
  • G.726 -16, -24, -32, -40
  • G.722 (Wideband)
  • GSM
  • iLBC
  • Speex und Speex-Wideband
  • Opus
  • G.729
  • Linear PCM (16 kHz, 44.1 kHz)

Echo-Unterdrückung

Unter der Echo-Cancellation versteht man die Analyse der gesendeten Daten und das Herausfiltern der darin befindlichenEmpfangsdaten. Durch Aktivieren dieser Option kann man also Verhindern, dass man über das Mikrofon wieder etwas aufnimmt, was aus den Lautsprechern ertönt.

SRTP

Sollen die Sprachdaten verschlüsselt werden, so kann die Option SRTP aktiviert werden. Da derzeit der Schlüsselaustausch selbst nochnicht verschlüsselt wird, hält sich der Nutzen noch in Grenzen. Ein erster Schritt ist es schon mal.

Die Gegenstelle muss ebenfalls SRTP unterstützen. Getestet wurde das bisher erfolgreich beim direkten IP-Ruf zu einem Grandstream GXP2000 als auch über den VoIP-Provider dus.net .

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: codecs

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

codecs

A codec is the short word for "coder and decoder"..

In this window you can disable individual codecs and change their priority. Themost preferred codec should be on top of the list. If this preferred codec is used belongs of the counterpart - if it supports this codec too.

The shown data rates are net values. In practice these values are much higher because of the encapsulation of speech data in RTP , UDP and finally in IP packets.The gross data rate for a G.711 codec is about 80 kBits/s. This is too much for modem and ISDNdial up connections! If such connectiona are used, these codecs should be disabled here.

Following codecs are supported by PhonerLite:

  • G.711 A-Law
  • G.711 µ-Law
  • G.726 -16, -24, -32, -40
  • G.722 (Wideband)
  • GSM
  • iLBC
  • Speex and Speex-Wideband
  • Opus
  • G.729
  • Linear PCM (16 kHz, 44.1 kHz)

Echo Cancellation

Echo Cancellation means analyzing of data to be sent and the filtering of containingreceived data. By activating this option you can avoid that you your microphone records data from the speakers.

SRTP

If speech data should be encrypted, you can activate the option SRTP . Atthe moment there is no encrypted/secure key exchange implemented in PhonerLite, so this option is not very useful, but a first step.

The peer (phone or provider) must support SRTP too. The actual implementation is tested against Grandstream GXP2000 and the German VoIP provider dus.net .

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: Kontakt zum Autor

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Kontakt

Ich bin per E-Mail erreichbar unter: info@phoner.de

Anschrift:
Heiko Sommerfeldt
Bachstr. 20
86836 Klosterlechfeld

Datenschutzerklärung

Im Forum können häufig gestellte Fragen nachgelesen werden. Man kann dort selbstverständlich auch eigene öffentliche Fragen und Kommentare einstellen.

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: contact the author

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

contact

You can contact me by email at: info@phoner.de

Address:
Heiko Sommerfeldt
Bachstr. 20
86836 Klosterlechfeld
Germany

Privacy policy

There is a German Forum for frequently asked questions. You can post there your questions or comments. English postings are welcome too!

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: Download

  • Unkompliziertes VoIP-Softphone mit Profil-Verwaltung und Kontaktverzeichnis
  • Deutsch Deutsch Englisch Englisch
  • Index
  • Allgemein
  • Konfiguration
  • Download
  • Kontakt

Download

Datei | Version | Größe
PhonerLiteSetup.exe (x64) | 3.03 | 6.70 MB
PhonerLite.zip (x64) | 3.03 | 6.11 MB
PhonerLiteBeta.zip | 3.04beta |

History

Letztes Update: 25. April 2022

3.03

  • New: Erweitertes Scripting (CLI)

3.02

  • Fix: Fehlendes Keep-Alive bei NAT-Erkennung

3.01

  • Fix: Power Management Einstellungen
  • Neu: CLI (integriert oder per telnet) für einfache Script-Steuerung

3.00

  • Fix: Contact-Header war abhängig von der gerufenen Request-URI bei eingehenden Rufen
  • Fix: Skalierung teilweise fehlerhast

2.99

  • Fix: ZRTP funktionierte nicht
  • Fix: Falsche IP-Adresse in SDP in speziellen Situationen

2.98

  • Fix: Sortierung im Log- und Telefonbuch
  • Fix: Wizard intern überarbeitet

2.97

  • Fix: gleich bleibender Contact-Header bei TCP/TLS-Verbindungen
  • New: Icon-Anzeige für Datei-Zugriffe (z.B. Mitschnitt)

2.96

  • Fix: Einfrieren der Applikation
  • Neu: Unterstützung für Komfortrauschen (CN)

2.95

  • Fix: Fehlende Rufnummernanzeige in der aktuellen Rufliste

2.94

  • Fix: Crash beim Import von Google Kontakten mit Bildern
  • Neu: Edge-Browser Support wenn Runtime installiert ist

2.93

  • Neu: Kurzwahltasten als DTMF über aktiven Ruf
  • Fix: Rufstatus-Icons

2.92

  • Neu: Google Kontakte über People API importieren

2.91

  • Fix: Doppelte Einträge im Logbuch

2.90

  • Fix: Fehlender Auslösegrund im Logbuch
  • Fix: Verbesserte Latenz

2.89

  • Fix: ungewollte Rufabbrüche

2.88

  • Fix: keine Fragmentierung zu großer UDP Nachrichten

2.87

  • Fix: Evtl. falscher Sendecodec bei Rufen zu VoLTE Mobiltelefonen
  • Fix: Fehlende Skalierung von Fenstern (nicht Hauptfenster)

2.86

  • Fix: "Thread handle" Error

2.85

  • Fix: Kleine Verbesserungen für die Barrierefreiheit

2.84

  • Fix: Import von Google Kontakten

2.83

  • Fix: Benutzung der "Default"-Soundkarte

2.82

  • Fix: Import von mehr als 500 Google Kontakten

2.81

  • Fix: Absturz nach Empfang von "Comfort Noise" Paketen mit falscher SSRC

2.80

  • Fix: Absturz in Remote Desktop Umgebung
  • Fix: Umschalten auf andere Soundkarte während des Rufs

2.79

  • Fix: Automatische Rufannahme ging nicht mehr

2.78

  • Fix: "Session Timers" können deaktiviert werden (wegen Rufabbrüchen nach bestimmter Zeit)
  • Fix: Reduziertes Flackern beim Verschieben auf anderen Monitor mit unterschiedlicher DPI

2.77

  • Fix: Behandlung von Fragmentierten SIP-Nachrichten bei TCP/TLS
  • Fix: Fehler beim Öffnen der Soundkarte (Wiedergabe) bei eingehenden Rufen

2.76

  • Fix: Absturz beim Import von Google Kontakten
  • Neu: Ukrainische Sprachunterstützung

2.75

  • Neu: Unterstützung für Dark Theme

2.74

  • Fix: Rufablehnung für unbekannte Bodies
  • Fix: Erste Versionsabfrage schlug immer fehl

2.73

  • Fix: internes/externes Klingeln
  • Fix: Längenbeschränkung des Anzeigenamens (UTF-8)

2.72

  • Fix: Session-Timers während des Haltens

2.71

  • Fix: Hänger nach Rufende
  • Fix: HID LED reset fehlgeschlagen

2.70

  • Fix: Versionsüberprüfung über HTTPS schlug fehl
  • Neu: Kurzwahltasten enthalten nun den Namen statt der Nummer

2.69

  • Fix: Rufabbrüche nach einigen Minuten (Session Timers)
  • Fix: größer werdende Schriften nach Dialog-Popups

2.68

  • Fix: Abfrage für neue Version
  • Fix: Periodischer Fokuswechsel beim Klingeln

2.67

  • Fix: Absturz beim minimierten Start
  • Fix: Dauer-Mute bei manchen Headsets

2.66

  • Fix: Import von FritzBox XML Dateien
  • Fix: kleinere interne Änderungen

2.65

  • Fix: Import von FritzBox XML Dateien
  • Fix: reduziertes Flackern beim Verschieben des Fensters auf anderen Monitor mit unterschiedlichem DPI
  • Fix: Registrierungs-Probleme bei Servern, welche den Contact-Header umschreiben

2.64

  • Fix: Zuordnung und Auswahl der Soundgeräte

2.63

  • Neu: Andocken am Bildschirmrand abschaltbar
  • Neu: Kurzwahltasten

2.62

  • Fix: Absturz nach einigen fehlgeschlagenen Registrierungen

2.61

  • Fix: Absturz beim Umbenennen eines Profils
  • Fix: Import der Google Kontakte (neue Zertifikate)
  • Neu: Exportiertes Telefonbuch der FritzBox (XML) kann per Drag&Drop importiert werden

2.60

  • Fix: Änderung der Skalierung zur Laufzeit

2.59

  • Fix: zu große Schriften nach Skalierung
  • Neu: Optionales Löschen von Einträgen im Logbuch, wenn diese älter als 30 Tage sind

2.58

  • Fix: Absturz nach Speichern während ein Ruf existiert

2.57

  • Fix: Skalierung bei hohen Bildschirmauflösungen

2.56

  • Neu: interne Haltemusik
  • Neu: DLL's für alte USB-Phones ausgelagert in USBphone.dll

2.55

  • Fix: Periodisches Update des Logbuchs bei aktivem Ruf

2.54

  • Fix: Falsche RTP Timestamp beim Halten
  • Neu: Anlegen eines Eintrags im Logbuch bei Rufbeginn
  • Neu: Option zum Anlegen/Löschen der Verknüpfung im Autostart-Ordner

2.53

  • Fix: Störgeräusch beim Resampling

2.52

  • Fix: Störgeräusch beim Resampling

2.51

  • Neu: Codec LPCM (L16/44100 und L16/16000)

2.50

  • Fix: Fehlende DNS SRV Abfrage in speziellen Fällen
  • Fix: Parameterübergabe für externe Applikationen

2.49

  • Fix: Namenszuordnung bei eingehenden Rufen
  • Neu: minimalistische HTTP-Behandlung auf dem SIP-Port

2.48

  • Fix: Auflegen-Probleme wegen unvollständiger Auswertung des "route sets"

2.47

  • Fix: Symbol wird aus der Taskleiste ausgeblendet

2.46

  • Fix: automatisches Dropdown-Verhalten für Nummernfeld einstellbar
  • Neu: G.729 Codec Unterstützung

2.45

  • Fix: Session Timers über INVITE statt UPDATE
  • Fix: Kein automatisches Auflegen, wenn 1 Sekunde lang keine Sprachdaten mehr empfangen werden.
  • Neu: Bearbeiten von Telefonbucheinträgen im Dialogfenster

2.44

  • Fix: Session Timers
  • Fix: Anzeigeprobleme beim Löschen von Logbucheinträgen

2.43

  • Fix: Stummschalter am Headset
  • Neu: Konfiguration für das Ablehnen von Rufen wenn der PC gesperrt ist über Rechtsklick auf den "Bitte nicht stören"-Button
  • Neu: Unterstützung für "Session Timers"

2.42

  • Fix: einige kleine Bugfixes
  • Neu: Eingehende Rufe werden abgelehnt wenn Windows gesperrt ist

2.41

  • Fix: falsche QoS Einstellungen

2.40

  • Fix: Google Kontakte: gleiche Nummer bei mehreren Kontakten
  • Neu: Italienische Übersetzung
  • Neu: Festes Datumsformat für Logbuch einstellbar
  • Neu: Schließen der Meldung (X-Button) für neue Anrufe entfernt Ruf aus Liste, d.h. es klingelt in PhonerLite nicht weiter

2.39

  • Fix: Dekodierung der Digest Informationen
  • Fix: Falsche Zuordnung eines Namens durch Nummer

2.38

  • Neu: Neue Icons und neues Programmicon
  • Neu: gleichziges Klingeln auf mehreren Geräten (z.B. HID und Soundkarte)

2.37

  • Fix: Absturz beim Beenden nach Import von Google Kontakten
  • Neu: Erweitertes Hauptmenü für Konfiguration

2.36

  • Fix: Schlechte Sprachqualität nach Aufbau eines zusätzlichen Rufs bzw. beim Makeln

2.35

  • Fix: falsche Angabe von Paketverlusten nach einem Halten
  • Neu: Option das Fenster nicht automatisch in den Vordergrund zu bringen (Rechtsklick auf Toolbar)

2.34

  • DNS Ergebnis einer SRV Abfrage wurde ignoriert

2.33

  • Fix: Profil konnte für bestimmte Windows Benutzernamen nicht geladen werden
  • Neu: eine Icons wurden verändert

2.32

  • Fix: Störgeräusche bei G.722 Codec

2.31

  • Fix: Falls STUN und SIP Server die gleiche Domain benutzen, konnte es passieren, dass die SIP Nachrichten zum STUN Server gesendet wurden
  • Fix: Applikation übergibt ermittelten Pfad zur "sipper.ini" der DLL, so dass diese nicht erneut suchen muss.

2.30

  • Fix: DTMF "0" funktionierte nicht mehr

2.29

  • Fix: URL mit Leerzeichen (%20)
  • Neu: Wildcard-Suche kann man deaktivieren
  • Neu: Telefonnummer mit Komma zur Pause und Nachwahl

2.28

  • Fix: Sprachqualität bei Resampling
  • Neu: Logbuch enthält nun eine Namenspalte

2.27

  • Fix: URL Handler Aktivierung/Deaktivierung
  • Fix: Headset-Tasten-Status nach Rufende

2.26

  • Fix: Import von Google-Kontakten
  • Neu: Speichern der Spaltenbreiten im Telefon- und Logbuch

2.25

  • Fix: Pfeifen durch Resampling
  • Neu: größere Buttons
  • Neu: Wildcards fürs Telefonbuch

2.24

  • Fix: Dekodieren von Multipart-Bodies
  • Neu: Sicherheitsabfrage beim Löschen von Profilen
  • Neu: URL-Protokollhandler nun einzeln einstellbar

2.23

  • Fix: verbesserte Interoparabilität bei SRTP
  • Fix: unvollständige Rufübergabe (Transfer) falls keim realm configuriert ist
  • Neu: geänderte Update Implementierung

2.22

  • Neu: Option zum Deaktivieren des Trenntons

2.21

  • Fix: Kein Halten bei eingehenden Rufen in manchen Situationen
  • Neu: Option zum Überprüfen des Benutzernamens bei eingehenden Rufen

2.20

  • Fix: Keine Unterstützung für SSLv3 mehr
  • Fix: HID-Unterstützung

2.19

  • Fix: Letzte Version lief nicht unter WinXP

2.18

  • Fix: Zurücksetzen des Klingel-Devices
  • Fix: Fehlgeschlagene Registrierung aufgrund von Authentifizierungsfehlern wurde nicht immer korrekt dargestellt
  • Neu: verbessere Unterstützung von HID-Headsets

2.17

  • Fix: einige kleine Bugfixes
  • Neu: Weniger Restriktionen bei der Anzahl gleichzeitiger Rufe

2.16

  • Fix: verbesserte Kompatibilität beim Aushandeln des Codecs Opus

2.15

  • Fix: potentielle Sicherheitslücke gefunden durch Jason Ostrom mit Stora

2.14

  • Fix: Schließen der TCP-Verbindung durch die Gegenstelle

2.13

  • Fix: Versionsüberprüfung

2.12

  • Fix: kein Senden mehr nach extrem hoher Systemlast
  • Neu: Behandlung von DTMF als Codec. Kann also auch aus- und eingeschaltet werden.

2.11

  • Fix: mehr Toleranz beim Ändern von SSRC und Sequence Number für empfangenes RTP

2.10

  • Fix: möglicher Absturtz nach eingehendem Anruf
  • Neu: Türkische Übersetzung

2.09

  • Fix: falsche interne IP-Adresse bei UPnP-Requests
  • Neu: Eingabefeld für Zielrufnummer ist nun viel größer

2.08

  • Fix: konsequentere DNS-SRV Abfrage
  • Fix: qop-Authentifizierung
  • Fix: Abbrechen langer Klingeltöne, wenn Klingelphase vorbei ist

2.07

  • Fix: Fehler beim Programmstart (Einfrieren)

2.06

  • Fix: Absturz mit "Device cannot be opened"
  • Fix: Google Contacts Bildqualität
  • Neu: Skalierung der ganzen Applikation bei Auflösungen mit hoher DPI Zahl
  • Neu: Klingel-Device auswählbar

2.05

  • Fix: Import der Google Kontakte
  • Fix: neuen Ruf aufbauen während eingehender Ruf klingelt

2.04

  • Fix: Authentifizierung mit qop

2.03

  • Fix: unnötige Thread-Generierung nach Fehlregistrierung
  • Fix: Opus-Codec Anpassungen
  • Fix: Falschinterpretation eines Kommntars als URL im Telefonbuch

2.02

  • Fix: Button-Beschriftungen für andere Sprachen als Deutsch und Englisch.
  • Neu: Kommantarfeld im Telefonbuch kann eine URL enthalten, die bei einem Anruf integriert dargestellt wird. Vorallem für Video-fähige Türsprecheinrichtungen ist dies interessant.

2.01

  • Fix: Falsche lokale IP-Adresse gesetzt in bestimmten NAT-Szenarien
  • Neu: Suche über alle Telefonbucheinträge in Combobox für Zielrufnummer
  • Neu: keine Unterstützung mehr für Windows2000

2.00

  • Fix: Gegenstellen mit anderem Signalisierungs-Port als Default (5060)
  • Neu: Telefonbuch-Import von Google Kontakten

1.99

  • Fix: ENUM Abfrage
  • Neu: Neue Icons

1.98

  • Fix: WASAPI liefert kürzere Aufnahmepuffer

1.97

  • Fix: fehlende Versionsänderung in re-INVITE Nachrichten
  • Fix: empfangene fragmentierte TCP/TLS-Nachrichten
  • Neu: Benutzung von WASAPI falls die Samplerate der Geräte-internen Samplerate entspricht

1.96

  • Fix: Falsche lokale IP-Adressen in einigen NAT und VPN Szenarien
  • Neu: Hinweis-Icon für verpasste Anrufe

1.95

  • Fix: kein Audio-Empfang nach Halten (SSRC-Änderung während des Rufs)

1.94

  • Fix: Yealink USB-Geräte unter Windows 7
  • Neu: automatische Rufannahme for CTI
  • Neu: TLS 1.2 Unterstützung

1.93

  • Fix: einige NAT-Probleme
  • Neu: einzelnes Hinweisfenster pro eingehendem Ruf
  • Neu: anklopfender Anruf mit anderem Klingelton

1.92

  • Fix: Konferenz mit aufbauender Verzögerung
  • Fix: Deadlock, Einfrieren
  • Neu: experimenteller Codec Opus , dafür kein CELT Codec mehr

1.91

  • Fix: Absturz bei HID-Zugriff (z.B. nach Standby)

1.90

  • Fix: Soundkartenansteuerung für Vista/Win7 (MMDevAPI)
  • Fix: Anzeige des Display-Namens der Gegenstelle

1.89

  • Fix: Einfrieren nach Rufaufbau
  • Fix: NAT zwischen zwei privaten IP-Adressbereichen

1.88

  • Fix: Packet Loss Concealment
  • Neu: Unterstützung für Codec CELT

1.87

  • Fix: Absturz nach geschlossenen TCP-Verbindungen vor der Rufannahme
  • Fix: Anzeige der verbundenen Rufnummer nach Änderung für verbunden Anrufe
  • Fix: Einige SUBSCRIBE Probleme
  • Fix: Keine DNS-SRV Abfrage wenn Port bekannt ist

1.86

  • Fix: Unterstützung für HID-Headsets (z.B. Jabra PRO 9470)

1.85

  • Fix: Rufanname eines zweiten eingehenden Rufes (Anklopfen)
  • Neu: Compilierung mit SSE Optimierungen

1.84

  • Fix: Spezialbehandlung für Rufe zur Fritz!Box
  • Fix: Bêhandlung von "302 Moved Temporarily"

1.83

  • Fix: STUN Dekodierung
  • Fix: Ermitteln der lokalen IP-Adresse bei VPNs ohne Netzwerkkarte (z.B. Fritz!Fernzugang)
  • Neu: Übersetzung ins Arabische
  • Neu: umgestaltete Oberfläche (Toolbar)

1.82

  • Fix: Rufabbruch wegen zu früh gesendetem re-INVITE

1.81

  • Fix: IPv6 Kompatibilität
  • Fix: einige kleine Änderungen

1.80

  • Fix: Absturz in mDNS bei sehr vielen Peers
  • Fix: Blind-Transfer mit vorherigem Halten
  • Fix: SRTP mit AES-256
  • Neu: initiale ZRTP Unterstützung

1.79

  • Fix: TCP-Verbindung und Via-Header
  • Neu: Profile unter anderem Namen speichern

1.78

  • Fix: Call Transfer (Statuscode 429)
  • Fix: einige kleine Änderungen

1.77

  • Fix: HID Geräte
  • Fix: Sortierung im Log- und telefonbuch
  • Fix: Entfernen der noch immer auftretenden "!IsInitialized" Meldung
  • Fix: einige Unicode Fehler

1.76

  • Fix: Timeout Warnung

1.75

  • Fix: WWW-Authorization für Rufe
  • Fix: kleinere Bugfixes

1.74

  • Fix: ACK für Rufe im privaten LAN aber externen Routen
  • Fix: Abstecken von USB-Geräten
  • Fix: HID kompatible USB-Telefone
  • Fix: UPnP-NAT für eingehende Rufe

1.73

  • Neu: Gesprächsmitschnitt in eine .wav Datei
  • Fix: automatische Erkennung bei Änderung der lokalen IP-Adressse

1.72

  • Fix: verbesserte Fehlerbehandlung
  • Fix: QoS ausschaltbar

1.71

  • Neu: Unterstützung für MousePhone VM-01L
  • Fix: kleinere Bugfixes

1.70

  • Neu: verbesserte Unterstützung für Yealink USB-Phones (z.B. P1K, P4K)

1.69

  • Neu: Konfiguration einer Telefonnummer

1.68

  • Fix: gleichzeitiges Halten von beiden Seiten
  • Neu: Unterstützung von PortableApps

1.67

  • Fix: Echo-Unterdrückung
  • Fix: Senden von iLBC im 30ms Modus

1.66

  • Fix: falsche Port-Angabe bei Registrierung wenn nicht der Default-Port verwendet wird
  • Fix: kleinere andere Verbesserungen
  • Neu: Unterstützung von UUI während eines Rufs - eine Art Mini-Chat zwischen PhonerLite-Instanzen

1.65

  • Fix: kleinere Bugfixes

1.64

  • Fix: kleinere Bugfixes
  • Neu: Schalter für G.726 AAL2

1.63

  • Fix: kleinere Bugfixes
  • .tel URI Unterstützung

1.62

  • Fix: Absturz nach Rufende

1.61

  • Fix: Direkter IP-zu-IP Ruf
  • Fix: Multicast-DNS (falsch gesetztes Bit)
  • Fix: Lautstärkeregler an HID-Headsets beenden Ruf
  • Neu: IPv6 Unterstützung

1.60

  • Fix: Übersetzungen für integriertes Update
  • Fix: kleinere Bugfixes

1.59

  • Fix: Registrierungsdauer aus Antwort vom Server
  • Fix: Jitter-Buffer und RTP-Paket Vertauscher
  • Fix: Lautstärkeregler für Aufnahme
  • Neu: Musik-On-Hold abschaltbar

1.58

  • Neu: spezielle Behandlung für Fritz!Box um externe Anmeldung zu ermöglichen
  • Neu: Meldungsfenster bei eingehenden Rufen
  • Neu: qWave QoS Unterstützung für Vista/Windows 7

1.57

  • Fix: Jitter Buffer

1.56

  • Fix: Eingehende RTCP Pakete (GoodBye)
  • Neu: bessere Unterstützung für HID-konforme Headsets
  • Neu: Sprachunterstützung für Russisch

1.55

  • Fix: viele kleinere Bugfixes
  • New: Hotkey-Konfiguration (keine Übersetzungen)

1.54

  • Neu: Unicode-Unterstützung
  • Fix: Auslesen der Konfiguration bei Profilumschaltung

1.53

  • Fix: Rufweiterleitung
  • Fix: Registrierung mit zu kurzem Intervall (Intervall too brief)
  • Fix: DirectSound unter Umständen gar nicht genutzt

1.52

  • Fix: Halten durch Gegenstelle wurde nicht korrekt dargestellt
  • Neu: Codec Unterstützung fpr G.726-16, -24 und -40

1.51

  • Fix: automatische Registrierung des integrierten COM Servers unter Vista
  • Neu: erweiterte Fehlerausgaben für TLS

1.50

1.49

  • Fix: RTP Parameter nach Halten
  • Fix: Jitterbuffer
  • Neu: UPnP NAT Port Freischaltung

1.48

  • Neu: eingebetteter COM-Server für Zugriff aus Fremdapplikationen
  • Neu: einstellbare Registrierungsdauer
  • Fix: UTF8-kodierter Displayname
  • Fix: viele kleinere Bugfixes

1.47

  • Fix: Registrierung nach Netzwerkfehler (Internet-Verbindung abgebrochen)
  • Fix: viele kleinere Bugfixes

1.46

  • Fix: vereinzelne Abstürze bei eingehenden Rufen
  • Fix: TLS-Verbindungen und Zertifikataustausch

1.45

  • Fix: TLS-Verbindung zu Nebenstellen, welche per mDNS ermittelt wurden
  • Fix: Soundkarten-Ansteuerung für Soundkarten mit falschem Timing (z.B. diverse OnBoard-Soundkarten im 8 kHz Modus)
  • Fix: Transfer: Rückfragegespräch klingelt noch
  • Neu: erste Versuche für "Einfachwahl"
  • Neu: Unterstützung für Skins von AlphaControls

1.44

  • Fix: diverse Fehler in der SIP-Verabeitung

1.43

  • Fix: Vermeidung von Vista VirtualStore-Ordner

1.42

  • Neu: Multicast-DNS (DNS Service Discovery)
  • Fix: Einfrieren beim Rufende

1.41

  • Neu: Sampleraten von 8, 11 und 16 kHz
  • Fix: Einfrieren während des Gesprächs

1.40

  • Neu: Transfer (Rufübergabe) von zwei Verbindungen
  • Neu: DNS SRV
  • Neu: G.722 Codec
  • Fix: kleinere Bugfixes

1.39

  • Fix: Codec Aushandlung
  • Fix: TLS
  • Neu: Konfiguration ausgesplittet in mehrere Seiten

1.38

  • Fix: ausgehender Ruf: falsches ACK
  • Fix: direkter Ruf über IP-Adresse

1.37

  • Fix: diverse kleine Bugs

1.36

  • Fix: Ändern von Telefonbucheinträgen
  • Fix: BYE mit Authentifizierung

1.35

  • Fix: eingehender Ruf ohne Benutzername
  • Neu: Unterstützung für schnurlose Headsets von Plantronics

1.34

  • Fix: Rufannahme

1.33

  • Neu: Unterstützung für das USB-Telefon P1K
  • Fix: Überarbeiterte Echo-Unterdrückung

1.32

  • Fix: Absturz bei Win98/2000

1.31

  • Fix: Codec-Aushandlung bei eingehenden Rufen

1.30

  • Fix: Lokale IP-Adresse bei VPN-Verbindungen
  • Neu: TLS

1.29

  • Fix: Einspielen des Klingeltons

1.28

  • Fix: Sprachqualität bei der Wiedergabe über die Soundkarte

1.27

  • Fix: Aufnahmequalität im DirectSound-Modus
  • Fix: konfigurierter SIP-Server Port

1.26

  • Fix: BYE mit richtigem Tag
  • Neu: Message Waiting Indication (MWI)
  • Neu: Web-Update aus Programm heraus

1.25

  • Fix: Echo-Unterdrückung funktioniert nun endlich

1.24

  • Fix: Diverse kleine Bugfixes

1.23

  • Fix: Periodische Registrierung
  • Neu: Unterstützung für das USB-Phone AU-210

1.22

  • Fix: Bessere Windows Vista Kompatibilität
  • Fix: Gelegentlicher Absturz beim Beenden

1.21

  • Fix: Auflegen bei Anrufen über NAT, aber ohne STUN

1.20

  • Fix: Eingehende Rufe wurden evtl. nicht angenommen
  • Fix: Speex Sprachqualität
  • Fix: automatische Erkennung der lokalen IP-Adresse

1.19

  • Fix: Memory-Leaks

1.18

  • Fix: Bessere SIP-Kompatibilität
  • Fix: Stabilität

1.17

  • Fix: Minimierter Start
  • Neu: keine manuelle Angabe der lokalen IP-Adresse mehr nötig

1.16

  • Fix: Rufabbruch

1.15

  • Neu: Unterstützung für USB-Phone AU-100

1.14

  • Fix: Automatischer Abbau des Empfangspuffers
  • Fix: STUN-Server Namensauflösung

1.13

  • Fix: Access Violation bei Verwendung der Kaspersky Security Suite 6.0

1.12

  • Neu: Setup Wizard bei Erststart
  • Fix: Diverse Bugfixes

1.11

  • Fix: eingehende Rufe ohne Codec
  • Neu: unterer Berech wegklappbar

1.10

  • Fix: Übersetztes Hauptmenü
  • Neu: Speichern der gesetzten Sprache
  • Neu: oSIP

1.09

  • Fix: SSE-Unterstützung entfernt

1.08

  • Neu: integrierter Klingelton für ausgehende Verbindungen
  • Neu: verschlüsselte Passwörter in der Ini-Datei
  • Fix: Verbesserung bei Stabilität, Sicherheit und Sprachqualität

1.07

  • Neu: LED zur Darstellung des Registrierungszustands

1.06

  • Fix: Echo Cancellation

1.05

  • Fix: Sprachqualität

1.04

  • Neu: Echo Cancellation
  • Fix: Sprachqualität

1.03

  • Fix: Speex-Codec

1.02

  • Neu: lokale Konferenz
  • Neu: spanische Sprachversion
  • Fix: Re-INVITE

1.01

  • Neu: -Codec

1.00

  • Initiale Version

  • Index
    • Allgemein
    • Logbuch
    • Telefonbuch
    • Nachrichten
    • Konfiguration
      • Server
      • Benutzer
      • Netzwerk
      • Codecs
      • Zertifikate
    • Rufumleitung
    • Statistik
    • CLI
    • Features
    • Forum
    • Kontakt
    • Lizenz


PhonerLite: download

  • Easy to use VoIP softphone with profile and contact management
  • German German English English
  • Index
  • General
  • Configuration
  • Download
  • Contact

download

file | version | size
PhonerLiteSetup.exe (x64) | 3.03 | 6.70 MB
PhonerLite.zip (x64) | 3.03 | 6.11 MB
PhonerLiteBeta.zip | 3.04beta |

History

Last update: April 25, 2022

3.03

  • New: improved scripting (CLI)

3.02

  • Fix: missing keep alives when NAT detected

3.01

  • Fix: power management settings
  • New: CLI (integrated or via telnet) for simple scripting

3.00

  • Fix: Contact header was dependend of called request-URI for incoming calls
  • Fix: some resize issues when scaling is active

2.99

  • Fix: ZRTP was broken
  • Fix: possible wrong IP address in SDP

2.98

  • Fix: sorting in log and phone book
  • Fix: wizard internally reworked

2.97

  • Fix: constant Contact header for TCP/TLS connections
  • New: icon indicator for wave file read/write access

2.96

  • Fix: application freezes
  • New: support for comfort noise (CN)

2.95

  • Fix: missing number in call list for outgoing calls

2.94

  • Fix: Crash importing Google Contacts with pictures
  • New: Edge-Browser Support if runtime is installed

2.93

  • New: speed dial buttons as DTMF for active call
  • Fix: call status icons

2.92

  • New: import Google Contacs via People API

2.91

  • Fix: double entries in logbook

2.90

  • Fix: missing cause in logbook
  • Fix: improve latency

2.89

  • Fix: unwanted call terminations

2.88

  • Fix: missing fragmentation of too long UDP messages

2.87

  • Fix: possible wrong send codec for calls to VoLTE mobile phones
  • Fix: no size scaling for other windows than main window

2.86

  • Fix: thread handle error

2.85

  • Fix: small improvements for accessibility

2.84

  • Fix: import of Google Contacts

2.83

  • Fix: usage of "Default" sound device

2.82

  • Fix: import more than 500 Google Contacts

2.81

  • Fix: crash after receiving comfort noise packets for wrong SSRC

2.80

  • Fix: crash on remote desktop environment
  • Fix: switch sound device during call

2.79

  • Fix: Auto answer didn't work anymore

2.78

  • Fix: Session Timers can be disabled (automated call termination in some situations)
  • Fix: Reduced flicker when moving to other monitor with different DPI

2.77

  • Fix: handling of fragmented SIP messages via TCP/TLS
  • Fix: Failed opening of playback sound device after incoming call

2.76

  • Fix: crash when importing Google Contacts
  • New: Ukrainian language added

2.75

  • New: dark theme support

2.74

  • Fix: reject calls with unsupported bodies
  • Fix: first version update check fails

2.73

  • Fix: internal/external ringing tone
  • Fix: length limitation of display name (UTF-8)

2.72

  • Fix: session timers while hold state

2.71

  • Fix: freeze after call termination
  • HID LED reset failed

2.70

  • Fix: version check failed via HTTPS
  • New: speed dial buttons show the name instead of number now

2.69

  • Fix: call terminations after some minutes (Session Timers)
  • Fix: increased font sizes after dialog popups

2.68

  • Fix: version update check
  • Fix: periodic focus change when ringing

2.67

  • Fix: crash when started minimized
  • Fix: mute problems for some headsets

2.66

  • Fix: import of FritzBox XML files
  • Fix: some minor internal changes

2.65

  • Fix: import of FritzBox XML files
  • Fix: reduce flicker when moving window to other monitor with different dpi
  • Fix: registration problems at servers overwriting Contact header

2.64

  • Fix: assignment of sound devices

2.63

  • New: docking on screen edges can be disabled
  • New: speed dial buttons

2.62

  • Fix: crash after some failed registrations

2.61

  • Fix: crash when rename profile
  • Fix: import Google contacts (new certificates)
  • New: exported phonebook from FritzBox as XML can be imported by drag&drop

2.60

  • Fix: change scaling at runtime

2.59

  • Fix: too large fonts after scaling
  • New: optional delete old entries in logbook that are older than 30 days

2.58

  • Fix: crash after saving config while a call is existing

2.57

  • Fix: scaling on high DPI

2.56

  • New: internal hold music
  • New: DLLs for old USB phones now separated in USBphone.dll

2.55

  • Fix: periodical update of logbook while active call

2.54

  • Fix: wrong RTP timestamps after hold
  • New: creation of entry in logbook when call starts
  • New: option to enable/disable run at system startup

2.53

  • Fix: resampling noise

2.52

  • Fix: resampling noise

2.51

  • New: codec LPCM (L16/44100 and L16/16000)

2.50

  • Fix: missing DNS SRV query in some cases
  • Fix: parameter for external applications

2.49

  • Fix: name assignment for incoming calls
  • New: very minimalistic HTTP handling on SIP port

2.48

  • Fix: call termination problems due incomplete route set handling

2.47

  • Fix: icon disappears from task bar

2.46

  • Fix: automatic dropdown for number field can be configured now
  • New: G.729 codec support

2.45

  • Fix: session timers using INVITE instead of UPDATE
  • Fix: no automatic call termination after receiving no speech data anymore for one second
  • New: edit phone book entries in dialog window

2.44

  • Fix: session timers
  • Fix: repaint loop when deleting log entries

2.43

  • Fix: mute button on headsets
  • New: configure call rejection when PC is locked via right click on "DND"-button
  • New: support for session timers

2.42

  • Fix: some minor fixes
  • New: reject incoming calls when Windows is locked

2.41

  • Fix: wrong QoS settings

2.40

  • Fix: Google Contacts: same number for different contacts
  • New: Italian translation
  • New: fixed date/time format for log book selectable
  • New: no further ringing when closing dialog via X button

2.39

  • Fix: decode digest information
  • Fix: wrong assignment of name for number

2.38

  • New: new icon set and main icon
  • New: ringing on multiple devices (e.g. HID and sound cound)

2.37

  • Fix: crash when terminating after import Google Contacts
  • New: enhanced main menu for configuration

2.36

  • Fix: bad voice quality after initiating additional calls or after call toggle

2.35

  • Fix: wrong packet loss after hold reported
  • New: option for not bringing window into front automatically (right click on toolbar)

2.34

  • fix: DNS result for SRV lookup was ignored

2.33

  • Fix: could not load profile for special Windows usernames
  • New: some icons changed

2.32

  • Fix: bad noise for G.,722 codec

2.31

  • Fix: in case of STUN and SIP server are the same domain, SIP messages may be sent to STUN server
  • Fix: application passes the path to "sipper.ini" to DLL, so DLL has not to search again

2.30

  • Fix: DTMF "0" didn't work anymore

2.29

  • Fix: URL containing escaped spaces (%20)
  • New: wildcard search can be disabled now
  • New: support for comma (",") in phone number to allow pause and dial after

2.28

  • Fix: speech quality for resampling
  • New: name column in logbook

2.27

  • Fix: URL handler actication/deactivation
  • Fix: headset button state after call termination

2.26

  • Fix: import of Google Contacts
  • New: save column widths in phone and log book

2.25

  • Fix: strange noise due resampling
  • New: larger buttons
  • New: wildcards in phonebook

2.24

  • Fix: decode of multipart bodies
  • New: confirmation dialog before deleting profile
  • New: URL protocol handler configurable individually

2.23

  • Fix: improved SRTP compatibility
  • Fix: incomplete call transfer if no realm was configured
  • New: changed update implementation

2.22

  • New: switch for disable disconnect tone

2.21

  • Fix: no hold for incoming calls in some situations
  • New: Option to check username for incoming calls

2.20

  • Fix: no SSLv3 support anymore
  • Fix: HID implementation

2.19

  • Fix: last version didn't work on WinXP

2.18

  • Fix: reset of ringing device
  • Fix: failed registration due authentication failure was not indicated in all scenarios
  • New: improved HID support for headsets

2.17

  • Fix: some minor fixes
  • New: less restrictions in number of simultaneous calls

2.16

  • Fix: improved compatibility for negotiation of codec Opus

2.15

  • Fix: potential security issue reported by Jason Ostrom with Stora

2.14

  • Fix: TCP connections closed by peer

2.13

  • Fix: version check failed

2.12

  • Fix: no audio sent anymore after heavy system load
  • New: handle outband DTMF as codec

2.11

  • Fix: more tolerant for SSRC and sequence number change of received RTP

2.10

  • Fix: possible crash after incoming call
  • New: Turkish translation

2.09

  • Fix: wrong internal IP address for UPnP requests
  • New: input field for destination number is much larger now

2.08

  • Fix: more consequent DNS-SRV queries
  • Fix: qop authentication
  • Fix: stop playing large ringing files after ringing phase is over

2.07

  • Fix: failed start of application (freeze)

2.06

  • Fix: crash with "Device cannot be opened"
  • Fix: Google Contacts picture quality
  • New: upscaling hole application for higher DPI resolutions
  • New: ringing device can be selected

2.05

  • Fix: import Google Contacts
  • Fix: initate call while incoming call is signaled

2.04

  • Fix: authentication with qop

2.03

  • Fix: thread generation after registration problems
  • Fix: Opus codec adaptions
  • Fix: wrong interpretation of comments as URL in phone book

2.02

  • Fix: button captions for other languages than German or English
  • New: comment field in phone book may contain an URL that will be displayed for a call. This may be of interest for video capable door line devices.

2.01

  • Fix: wrong local IP set in some strange NAT scenarios
  • New: search though all phone book entries in combobox for destination number
  • New: no support for Windows2000 anymore

2.00

  • Fix: peers with different signaling port than default (5060)
  • New: phone book import of Google Contacts

1.99

  • Fix: ENUM lookup
  • New: new icons

1.98

  • Fix: WASAPI captures smaller buffers

1.97

  • Fix: missing version increment for re-INVITE
  • Fix: received fragmented TCP/TLS messages
  • New: using WASAPI on Windows 7 when sample rate matches the device internal sample rate

1.96

  • Fix: wrong local IP addresses in some NAT or VPN scenarios
  • Fix: ZRTP masquerading
  • New: notification icon for missed calls
  • New: warning when closing the application (can be deactivated)

1.95

  • Fix: no received audio after HOLD (SSRC change during call)

1.94

  • Fix: Yealink USB devices running on Windows 7
  • New: auto answer for CTI
  • New: TLS 1.2 support

1.93

  • Fix: some NAT problems
  • New: every incoming call gets its own alert window
  • New: new ringtone for call waiting

1.92

  • Fix: increasing delay for conferences
  • Fix dead locks
  • New: experimental codec Opus , no direct CELT codec anymore

1.91

  • Fix: crash for HID access (e.g. after standby)

1.90

  • Fix: sound device handling for Vista/Win7 using MMDevAPI
  • Fix: show display name of remote party

1.89

  • Fix: deadlock after call establishment
  • Fix: NAT between two private IP address ranges

1.88

  • Fix: Pack Loss Concealment
  • New: support for codec CELT
  • New: sampling rates up to 48 kHz

1.87

  • Fix: crash for closed TCP connections before call establishment
  • Fix: show changed connected party number while in active call
  • Fix: some SUBSCRIBE issues
  • Fix: no SRV lookup if port is known

1.86

  • Fix: support for HID-Headsets (e.g. Jabra PRO 9470)

1.85

  • Fix: answering of incoming second call (call waiting)
  • New: compilation with SSE optimization

1.84

  • Fix: special handling for calls to Fritz!Box
  • Fix: handling of "302 Moved Temporarily"

1.83

  • Fix: STUN decoding
  • Fix: get local IP address for VPN without network adapter (e.g. Fritz!Fernzugang)
  • New: translation to Arabic
  • New: modified GUI (toolbar)

1.82

  • Fix: Failed calls due to re-INVITE sent too early

1.81

  • Fix: IPv6 compatibility
  • Fix: some minor fixes

1.80

  • Fix: crash in mDNS with a lot of peers
  • Fix: blind transfer with hold before
  • Fix: SRTP using AES-256
  • New: initial ZRTP support

1.79

  • Fix: TCP connections and Via header
  • New: save profiles with different name

1.78

  • Fix: call transfer (status code 429)
  • Fix: some minor fixes

1.77

  • Fix: HID device support
  • Fix: sorting log and phone book
  • Fix: incoming SRTP channel failed
  • Fix: removed still annoying "!IsInitialized" message

1.76

  • Fix: Timeout warning

1.75

  • Fix: WWW-Authorization for calls
  • Fix: some minor fixes

1.74

  • Fix: ACK for calls in private LANs but external route
  • Fix: unplug USB devices
  • Fix: HID compatible USB phones
  • Fix: UPnP-NAT for incoming calls

1.73

  • Fix: automated detection of local IP address change

1.72

  • Fix: improved error handling
  • Fix: QoS can be deactivated

1.71

  • New: support for MousePhone VM-01L

1.70

  • New: improved support for Yealink USB phones (e.g. P1K, P4K)

1.69

  • New: configuration of a calling phone number

1.68

  • Fix: hold from both sides
  • New: support for PortableApps

1.67

  • Fix: Echo cancellation
  • Fix: sending iLBC in 30ms mode

1.66

  • Fix: wrong port in REGISTER if not using default port
  • Fix: some other minor improvements
  • New: support for UUI while call - some kind of mini chat between PhonerLite instances

1.65

  • Fix: some minor fixes

1.64

  • Fix: some minor fixes
  • New: G.726 switch for AAL2

1.63

  • New: .tel URI support

1.62

  • Fix: crash after call termination

1.61

  • Fix: direct IP-to-IP call
  • Fix: Multicast-DNS (wrong bit)
  • Fix: volume control on HID headsets terminate call
  • New: IPv6 support

1.60

  • Fix: translation for integrated update
  • Fix some minor fixes

1.59

  • Fix: registration expiry from server response
  • Fix: jitter buffer and RTP misorder
  • Fix: volume control for recording device
  • New: music-on-hold disableable

1.58

  • New: special handling for Fritz!Box to enable external registration
  • New: Alert box for incoming calls
  • New: qWave QoS support for Vista/Windows 7
  • Fix: minor bugfixes

1.57

  • Fix: Jitter Buffer

1.56

  • Fix: incoming RTCP (GoodBye)
  • New: better support for HID compatible headsets
  • New: Russian language support

1.55

  • Fix: minor bugfixes
  • New: configure hotkeys (missing translatiuons)

1.54

  • New: Unicode support
  • Fix: reading of configuration when switching profile

1.53

  • Fix: call forwarding
  • Fix: registration rejection: "intervall too brief"

1.52

  • Fix: incoming hold was not displayd correctly
  • New: codec support for G.726-16, -24 and -40

1.51

  • Fix: initial startup on Vista for registrarion of integrated COM server
  • New: some more TLS failure output in log

1.50

  • Fix: some minor bugfixes

1.49

  • Fix: RTP parameter after hold
  • New: UPnP NAT port forwarding

1.48

  • New: embedded COM server for access from other applications
  • New: registration period configurable
  • Fix: UTF8 coded display names
  • Fix: a lot of small bugfixes

1.47

  • Fix: a lot of small bugfixes

1.46

  • Fix: crash for some incoming calls
  • Fix: TLS connections and certificate exchange

1.45

  • Fix: TLS connection to peers found by MDNS
  • Fix: sound card handling for hardware with wrong timing (e.g. some onbard sound cards working in 8 kHz mode)
  • Fix: transfer: consultation call is still ringing
  • New: first try to support overlap dial
  • New: support for skins of AlphaControls

1.44

  • Fix: some bugs in SIP handling
  • New: support for "dialog-info" in phone book

1.43

  • Fix: avoid Vista VirtualStore folder

1.42

  • New: Multicast-DNS (DNS Service Discovery)

1.41

  • New: sampling rates: 8, 11 and 16 kHz
  • New: Speex-wideband codec
  • Fix: speech quality in conferences
  • Fix: freeze during calls

1.40

  • New: transfer of two calls
  • New: DNS SRV

1.39

  • Fix: codec negotiation
  • Fix: TLS

1.38

  • Fix: direct call to IP address

1.37

  • Fix: some minor bugs

1.36

  • Fix: editing phone book entries
  • Fix: BYE with authentication

1.35

  • Fix: incoming call without username

1.34

1.33

  • New: support for USB phone P1K
  • Fix: modified echo cancelling

1.32

  • Fix: crash on Win98/2000 systems

1.31

  • Fix: improved compatibility with some providers
  • Fix: codec negotiation for incoming calls

1.30

  • Fix: local IP address for VPN connections
  • New: TLS

1.29

  • Fix: generating ring tone

1.28

  • Fix: quality of playback over sound card

1.27

  • Fix: voice capture quality in DirectSound mode
  • Fix: configured SIP server port

1.26

  • Fix: BYE using correct tag
  • New: Message Waiting Indication (MWI)
  • New: Web update from application

1.25

  • Fix: echo canceller finally works

1.24

  • Fix: some minor fixes

1.23

  • Fix: periodical registration
  • New: support for USB phone AU-210

1.22

  • Fix: better Windows Vista compatibility
  • Fix: occasional crash when terminating application

1.21

  • Fix: hang up calls over NAT, but without STUN
  • New: application icon changes during registration

1.20

  • Fix: incoming calls were rejected sometimes
  • Fix: Speex speech quality
  • Fix: automatic detection of local IP address

1.19

  • Fix: Memory leaks

1.18

  • Fix: Better SIP compatibility
  • Fix: stability

1.17

  • Fix: Minimized start
  • New: No configuration of own local IP address necessary any more

1.16

  • Fix: Cancel call

1.15

  • New: SRTP support
  • New: Support for USB phone AU-100

1.14

  • Fix: Automatic reduction of receive buffer
  • Fix: STUN server name resolution

1.13

  • Fix: Access violation when using Kaspersky Security Suite 6.0

1.12

  • New: Setup Wizard for first start
  • Fix: some bug fixes

1.11

  • Fix: improved stability
  • Fix: incoming calls with codecs
  • New: lower part can be hided

1.10

  • Fix: translated main menu
  • New: saving of selected language
  • New: oSIP libraries are not linked static anymore, DLLs used instead

1.09

1.08

  • New: integrated ringback tone for outgoing connections
  • New: encrypted passwords in ini file
  • Fix: improvement of stability, security and speech quality

1.07

  • New: LED for visualizing registration state
  • Fix: some minor bugs

1.06

  • Fix: Echo Cancellation

1.05

  • Fix Speech quality

1.04

  • New: Echo cancellation
  • Fix: Speech quality

1.03

  • Fix: Speex codec

1.02

  • New: local conference
  • New: Spanish language support
  • Fix: Re-INVITE

1.01

  • New: Help file (English and German)
  • Speex codec

1.00

  • Initial version

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • statistics
    • CLI
    • features
    • forum
    • contact
    • license


PhonerLite: DSGVO-Datenschutzerklärung

Datenschutzerklärung

Personenbezogene Daten (nachfolgend zumeist nur „Daten“ genannt) werden von uns nur im Rahmen der Erforderlichkeit sowie zum Zwecke der Bereitstellung eines funktionsfähigen und nutzerfreundlichen Internetauftritts, inklusive seiner Inhalte und der dort angebotenen Leistungen, verarbeitet.

Gemäß Art. 4 Ziffer 1. der Verordnung (EU) 2016/679, also der Datenschutz-Grundverordnung (nachfolgend nur „DSGVO“ genannt), gilt als „Verarbeitung“ jeder mit oder ohne Hilfe automatisierter Verfahren ausgeführter Vorgang oder jede solche Vorgangsreihe im Zusammenhang mit personenbezogenen Daten, wie das Erheben, das Erfassen, die Organisation, das Ordnen, die Speicherung, die Anpassung oder Veränderung, das Auslesen, das Abfragen, die Verwendung, die Offenlegung durch Übermittlung, Verbreitung oder eine andere Form der Bereitstellung, den Abgleich oder die Verknüpfung, die Einschränkung, das Löschen oder die Vernichtung.

Mit der nachfolgenden Datenschutzerklärung informieren wir Sie insbesondere über Art, Umfang, Zweck, Dauer und Rechtsgrundlage der Verarbeitung personenbezogener Daten, soweit wir entweder allein oder gemeinsam mit anderen über die Zwecke und Mittel der Verarbeitung entscheiden. Zudem informieren wir Sie nachfolgend über die von uns zu Optimierungszwecken sowie zur Steigerung der Nutzungsqualität eingesetzten Fremdkomponenten, soweit hierdurch Dritte Daten in wiederum eigener Verantwortung verarbeiten.

Unsere Datenschutzerklärung ist wie folgt gegliedert:

I. Informationen über uns als Verantwortliche
II. Rechte der Nutzer und Betroffenen
III. Informationen zur Datenverarbeitung

I. Informationen über uns als Verantwortliche

Verantwortlicher Anbieter dieses Internetauftritts im datenschutzrechtlichen Sinne ist:

Heiko Sommerfeldt
Bachstr. 20
86836
Klosterlechfeld

E-Mail: info@phoner.de

II. Rechte der Nutzer und Betroffenen

Mit Blick auf die nachfolgend noch näher beschriebene Datenverarbeitung haben die Nutzer und Betroffenen das Recht

  • auf Bestätigung, ob sie betreffende Daten verarbeitet werden, auf Auskunft über die verarbeiteten Daten, auf weitere Informationen über die Datenverarbeitung sowie auf Kopien der Daten (vgl. auch Art. 15 DSGVO);
  • auf Berichtigung oder Vervollständigung unrichtiger bzw. unvollständiger Daten (vgl. auch Art. 16 DSGVO);
  • auf unverzügliche Löschung der sie betreffenden Daten (vgl. auch Art. 17 DSGVO), oder, alternativ, soweit eine weitere Verarbeitung gemäß Art. 17 Abs. 3 DSGVO erforderlich ist, auf Einschränkung der Verarbeitung nach Maßgabe von Art. 18 DSGVO;
  • auf Erhalt der sie betreffenden und von ihnen bereitgestellten Daten und auf Übermittlung dieser Daten an andere Anbieter/Verantwortliche (vgl. auch Art. 20 DSGVO);
  • auf Beschwerde gegenüber der Aufsichtsbehörde, sofern sie der Ansicht sind, dass die sie betreffenden Daten durch den Anbieter unter Verstoß gegen datenschutzrechtliche Bestimmungen verarbeitet werden (vgl. auch Art. 77 DSGVO).

Darüber hinaus ist der Anbieter dazu verpflichtet, alle Empfänger, denen gegenüber Daten durch den Anbieter offengelegt worden sind, über jedwede Berichtigung oder Löschung von Daten oder die Einschränkung der Verarbeitung, die aufgrund der Artikel 16, 17 Abs. 1, 18 DSGVO erfolgt, zu unterrichten. Diese Verpflichtung besteht jedoch nicht, soweit diese Mitteilung unmöglich oder mit einem unverhältnismäßigen Aufwand verbunden ist. Unbeschadet dessen hat der Nutzer ein Recht auf Auskunft über diese Empfänger.

Ebenfalls haben die Nutzer und Betroffenen nach Art. 21 DSGVO das Recht auf Widerspruch gegen die künftige Verarbeitung der sie betreffenden Daten, sofern die Daten durch den Anbieter nach Maßgabe von Art. 6 Abs. 1 lit. f) DSGVO verarbeitet werden. Insbesondere ist ein Widerspruch gegen die Datenverarbeitung zum Zwecke der Direktwerbung statthaft.

III. Informationen zur Datenverarbeitung

Ihre bei Nutzung unseres Internetauftritts verarbeiteten Daten werden gelöscht oder gesperrt, sobald der Zweck der Speicherung entfällt, der Löschung der Daten keine gesetzlichen Aufbewahrungspflichten entgegenstehen und nachfolgend keine anderslautenden Angaben zu einzelnen Verarbeitungsverfahren gemacht werden.

Serverdaten

Aus technischen Gründen, insbesondere zur Gewährleistung eines sicheren und stabilen Internetauftritts, werden Daten durch Ihren Internet-Browser an uns bzw. an unseren Webspace-Provider übermittelt. Mit diesen sog. Server-Logfiles werden u.a. Typ und Version Ihres Internetbrowsers, das Betriebssystem, die Website, von der aus Sie auf unseren Internetauftritt gewechselt haben (Referrer URL), die Website(s) unseres Internetauftritts, die Sie besuchen, Datum und Uhrzeit des jeweiligen Zugriffs sowie die IP-Adresse des Internetanschlusses, von dem aus die Nutzung unseres Internetauftritts erfolgt, erhoben.

Diese so erhobenen Daten werden vorrübergehend gespeichert, dies jedoch nicht gemeinsam mit anderen Daten von Ihnen.

Diese Speicherung erfolgt auf der Rechtsgrundlage von Art. 6 Abs. 1 lit. f) DSGVO. Unser berechtigtes Interesse liegt in der Verbesserung, Stabilität, Funktionalität und Sicherheit unseres Internetauftritts.

Die Daten werden spätestens nach sieben Tage wieder gelöscht, soweit keine weitere Aufbewahrung zu Beweiszwecken erforderlich ist. Andernfalls sind die Daten bis zur endgültigen Klärung eines Vorfalls ganz oder teilweise von der Löschung ausgenommen.


PhonerLite: Privacy Policy

Privacy Policy

Personal data (usually referred to just as "data" below) will only be processed by us to the extent necessary and for the purpose of providing a functional and user-friendly website, including its contents, and the services offered there.

Per Art. 4 No. 1 of Regulation (EU) 2016/679, i.e. the General Data Protection Regulation (hereinafter referred to as the "GDPR"), "processing" refers to any operation or set of operations such as collection, recording, organization, structuring, storage, adaptation, alteration, retrieval, consultation, use, disclosure by transmission, dissemination, or otherwise making available, alignment, or combination, restriction, erasure, or destruction performed on personal data, whether by automated means or not.

The following privacy policy is intended to inform you in particular about the type, scope, purpose, duration, and legal basis for the processing of such data either under our own control or in conjunction with others. We also inform you below about the third-party components we use to optimize our website and improve the user experience which may result in said third parties also processing data they collect and control.

Our privacy policy is structured as follows:

I. Information about us as controllers of your data
II. The rights of users and data subjects
III. Information about the data processing

I. Information about us as controllers of your data

The party responsible for this website (the "controller") for purposes of data protection law is:

Heiko Sommerfeldt
Bachstr. 20
86836 Klosterlechfeld
Germany

Email: info@phoner.de

II. The rights of users and data subjects

With regard to the data processing to be described in more detail below, users and data subjects have the right

  • to confirmation of whether data concerning them is being processed, information about the data being processed, further information about the nature of the data processing, and copies of the data (cf. also Art. 15 GDPR);
  • to correct or complete incorrect or incomplete data (cf. also Art. 16 GDPR);
  • to the immediate deletion of data concerning them (cf. also Art. 17 DSGVO), or, alternatively, if further processing is necessary as stipulated in Art. 17 Para. 3 GDPR, to restrict said processing per Art. 18 GDPR;
  • to receive copies of the data concerning them and/or provided by them and to have the same transmitted to other providers/controllers (cf. also Art. 20 GDPR);
  • to file complaints with the supervisory authority if they believe that data concerning them is being processed by the controller in breach of data protection provisions (see also Art. 77 GDPR).

In addition, the controller is obliged to inform all recipients to whom it discloses data of any such corrections, deletions, or restrictions placed on processing the same per Art. 16, 17 Para. 1, 18 GDPR. However, this obligation does not apply if such notification is impossible or involves a disproportionate effort. Nevertheless, users have a right to information about these recipients.

Likewise, under Art. 21 GDPR, users and data subjects have the right to object to the controller's future processing of their data pursuant to Art. 6 Para. 1 lit. f) GDPR. In particular, an objection to data processing for the purpose of direct advertising is permissible.

III. Information about the data processing

Your data processed when using our website will be deleted or blocked as soon as the purpose for its storage ceases to apply, provided the deletion of the same is not in breach of any statutory storage obligations or unless otherwise stipulated below.

Server data

For technical reasons, the following data sent by your internet browser to us or to our server provider will be collected, especially to ensure a secure and stable website: These server log files record the type and version of your browser, operating system, the website from which you came (referrer URL), the webpages on our site visited, the date and time of your visit, as well as the IP address from which you visited our site.

The data thus collected will be temporarily stored, but not in association with any other of your data.

The basis for this storage is Art. 6 Para. 1 lit. f) GDPR. Our legitimate interest lies in the improvement, stability, functionality, and security of our website.

The data will be deleted within no more than seven days, unless continued storage is required for evidentiary purposes. In which case, all or part of the data will be excluded from deletion until the investigation of the relevant incident is finally resolved.


PhonerLite Русский

  • Легкий в использовании VoIP софтфон с управлением профилями и контактами
  • немецкий немецкий английский английский русский русский
  • индекс
  • вообще
  • конфигурация
  • скачать
  • контакт

Что такое PhonerLite?

PhonerLite это легкое и простое приложение для Windows. PhonerLite позволяет вашему ПК использоваться для интернет телефонии (VoIP , голос поверх IP ). Требуется полнодуплексная звуковая карта, микрофон и динамики (или наушники), интернет подключение, эккаунт от провайдера, поддерживающий протокол SIP. PhonerLite поддерживание несколько SIP профилей, каждый из которных настраивается независимо.

PhonerLite поддерживавает передовые методы шифрования TLS, SRTP и ZRTP.

Почему "PhonerLite" это правильное имя?

  • Phoner: Существует приложение называемое Phoner, с котороым PhonerLite делит общий исходный код и файл "sipper.dll". Все VoIP специфические конфигурации одни и те же и могут использоваться и в Phoner и в PhonerLite без преобразований Если Phoner и PhonerLite инсталлированы в один и тот же каталог, они используют одну и ту же DLL и конфигурационные данные (sipper.ini). Основное отличие PhonerLite использует другой интерфейс GUI чем Phoner.
  • Lite: Также как в Coke light эпитет light подразумевает легкую версию оригинального продукта. PhonerLite не позволяет экономить калории, но сохраняет ресурсы - в нашем случае оперативную память. PhonerLite значительно легче в использовании чем Phoner. Это преимущество дает также недостатки: отсутствует автоответчик и преобразование текста в речь (TTS).

PhonerLite бесплатен?

ДА! PhonerLite это бесплатное программное обеспечение. PhonerLite может использоваться, копироваться, предлагаться для скачивания повторно без любых выплат в частном и коммерческом окружении. Но PhonerLite это не программное обеспечение с открытым исходным кодом. Больше информации относительно лицензирование смотрите здесь.

  • Index
    • general
    • log book
    • phone book
    • messages
    • configuration
      • server
      • user
      • network
      • codecs
      • certificates
    • forwarding
    • CLI
    • statistics
    • features
    • forum
    • contact
    • license